Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
262eb57e
Commit
262eb57e
authored
Apr 15, 2019
by
Eetu
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
[lipstick] Add windiw raising and lowering back
parent
f72213f9
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
31 additions
and
2 deletions
+31
-2
0001-lower-raise-window-Add-window-lowering-and-raising.patch
...-lower-raise-window-Add-window-lowering-and-raising.patch
+27
-0
lipstick_git.bb
recipes-nemomobile/lipstick/lipstick_git.bb
+4
-2
No files found.
recipes-nemomobile/lipstick/lipstick/0001-lower-raise-window-Add-window-lowering-and-raising.patch
0 → 100644
View file @
262eb57e
From b7d0db08c5c691b139a3eaaee32703db6405a9c9 Mon Sep 17 00:00:00 2001
From: Eetu <eetu.kahelin@necunos.com>
Date: Mon, 15 Apr 2019 16:20:24 +0300
Subject: [PATCH] [lower/raise window] Add window lowering and raising
---
src/compositor/lipstickcompositor.cpp | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/src/compositor/lipstickcompositor.cpp b/src/compositor/lipstickcompositor.cpp
index e4e6b911..2deb081c 100644
--- a/src/compositor/lipstickcompositor.cpp
+++ b/src/compositor/lipstickcompositor.cpp
@@ -188,6 +188,13 @@
void LipstickCompositor::onExtendedSurfaceReady(QtWayland::ExtendedSurface *extS
LipstickCompositorWindow *window = surfaceWindow(surface);
if(window)
window->setExtendedSurface(extSurface);
+
+ connect(extSurface, &QtWayland::ExtendedSurface::raiseRequested, this, [this, window]() {
+ windowRaised(window);
+ });
+ connect(extSurface, &QtWayland::ExtendedSurface::lowerRequested, this, [this, window]() {
+ windowLowered(window);
+ });
}
bool LipstickCompositor::openUrl(QWaylandClient *client, const QUrl &url)
recipes-nemomobile/lipstick/lipstick_git.bb
View file @
262eb57e
...
...
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = "git://github.com/AsteroidOS/lipstick.git;protocol=https \
file://0001-Disables-tests-and-doc.patch \
file://Notifications/"
file://Notifications/ \
file://0001-lower-raise-window-Add-window-lowering-and-raising.patch \
"
SRCREV = "cf9b21228764dc87bbe22c3d187e322c793a4930"
PR = "r1"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment