Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
539357e1
Commit
539357e1
authored
Nov 24, 2016
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
qtwayland: two patches are not needed anymore since meta-qt5 got upgraded to Qt 5.6.2
parent
73cef29d
Changes
3
Expand all
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
1 addition
and
821 deletions
+1
-821
0002-Revert-Support-EGLStream-in-wayland-egl.patch
...ayland/0002-Revert-Support-EGLStream-in-wayland-egl.patch
+0
-766
0003-Fix-build-with-no-accessibility.patch
.../qt5/qtwayland/0003-Fix-build-with-no-accessibility.patch
+0
-52
qtwayland_git.bbappend
recipes-qt/qt5/qtwayland_git.bbappend
+1
-3
No files found.
recipes-qt/qt5/qtwayland/0002-Revert-Support-EGLStream-in-wayland-egl.patch
deleted
100644 → 0
View file @
73cef29d
This diff is collapsed.
Click to expand it.
recipes-qt/qt5/qtwayland/0003-Fix-build-with-no-accessibility.patch
deleted
100644 → 0
View file @
73cef29d
From 3bcfbed3ee7db06765dcf794f538333c4c33c4c5 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Mon, 12 Sep 2016 22:50:16 +0200
Subject: [PATCH] Fix build with no-accessibility
---
src/client/qwaylandintegration.cpp | 2 ++
src/client/qwaylandintegration_p.h | 3 +++
2 files changed, 5 insertions(+)
diff --git a/src/client/qwaylandintegration.cpp b/src/client/qwaylandintegration.cpp
index 39fff53..b9bc4ad 100644
--- a/src/client/qwaylandintegration.cpp
+++ b/src/client/qwaylandintegration.cpp
@@ -243,10 +243,12 @@
QVariant QWaylandIntegration::styleHint(StyleHint hint) const
return QPlatformIntegration::styleHint(hint);
}
+#ifndef QT_NO_ACCESSIBILITY
QPlatformAccessibility *QWaylandIntegration::accessibility() const
{
return mAccessibility;
}
+#endif
QPlatformServices *QWaylandIntegration::services() const
{
diff --git a/src/client/qwaylandintegration_p.h b/src/client/qwaylandintegration_p.h
index 987d805..18a343b 100644
--- a/src/client/qwaylandintegration_p.h
+++ b/src/client/qwaylandintegration_p.h
@@ -46,6 +46,7 @@
//
#include <qpa/qplatformintegration.h>
+#include <qpa/qplatformaccessibility.h>
#include <QtWaylandClient/private/qwaylandclientexport_p.h>
QT_BEGIN_NAMESPACE
@@ -88,7 +89,9 @@
public:
QVariant styleHint(StyleHint hint) const Q_DECL_OVERRIDE;
+#ifndef QT_NO_ACCESSIBILITY
QPlatformAccessibility *accessibility() const Q_DECL_OVERRIDE;
+#endif
QPlatformServices *services() const Q_DECL_OVERRIDE;
--
2.9.3
recipes-qt/qt5/qtwayland_git.bbappend
View file @
539357e1
FILESEXTRAPATHS_prepend := "${THISDIR}/qtwayland:"
FILESEXTRAPATHS_prepend := "${THISDIR}/qtwayland:"
SRC_URI += " file://0001-Forces-GLES2-the-dirty-way.patch \
SRC_URI += " file://0001-Forces-GLES2-the-dirty-way.patch"
file://0002-Revert-Support-EGLStream-in-wayland-egl.patch \
file://0003-Fix-build-with-no-accessibility.patch"
DEPENDS_remove = "${XKB_DEPENDS}"
DEPENDS_remove = "${XKB_DEPENDS}"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment