Commit 751bb311 authored by Florent Revest's avatar Florent Revest

mce: Bump SRCREV and rewrite patches on new codebase

parent eaf01824
From 0d3f0e2a211a75a25557bc4421f9df5de93e9d27 Mon Sep 17 00:00:00 2001
From 6d791c7121db5272590dcb9d4f225f5f9c9259c0 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Mon, 12 Sep 2016 18:56:52 +0200
Date: Tue, 20 Feb 2018 15:05:21 +0100
Subject: [PATCH] Fixes build
---
Makefile | 104 +++++++++++++++++++++++++++++++--------------------------------
1 file changed, 52 insertions(+), 52 deletions(-)
Makefile | 98 ++++++++++++++++++++++++++++++++--------------------------------
1 file changed, 49 insertions(+), 49 deletions(-)
diff --git a/Makefile b/Makefile
index aaef621..0042d37 100644
index 9d93ac2..d1d7602 100644
--- a/Makefile
+++ b/Makefile
@@ -73,7 +73,7 @@ endif
@@ -85,7 +85,7 @@ endif
PKG_CONFIG ?= pkg-config
# Whether to enable DEVEL release logging
......@@ -20,7 +20,7 @@ index aaef621..0042d37 100644
# Whether to enable support for libhybris plugin
ENABLE_HYBRIS ?= y
@@ -180,70 +180,70 @@ DBUSCONF := mce.conf
@@ -193,70 +193,70 @@ DBUSCONF := mce.conf
# ----------------------------------------------------------------------------
# C Preprocessor
......@@ -79,7 +79,19 @@ index aaef621..0042d37 100644
-CFLAGS += -Waggregate-return
-CFLAGS += -Wmissing-noreturn
-CFLAGS += -Wnested-externs
-#CFLAGS += -Wchar-subscripts (-Wall does this)
+override CFLAGS += -Wall
+override CFLAGS += -Wextra
+override CFLAGS += -Wpointer-arith
+override CFLAGS += -Wundef
+override CFLAGS += -Wcast-align
+override CFLAGS += -Wshadow
+override CFLAGS += -Wbad-function-cast
+override CFLAGS += -Wwrite-strings
+override CFLAGS += -Wsign-compare
+override CFLAGS += -Waggregate-return
+override CFLAGS += -Wmissing-noreturn
+override CFLAGS += -Wnested-externs
#CFLAGS += -Wchar-subscripts (-Wall does this)
-CFLAGS += -Wmissing-prototypes
-CFLAGS += -Wformat-security
-CFLAGS += -Wformat=2
......@@ -91,28 +103,9 @@ index aaef621..0042d37 100644
-CFLAGS += -Wold-style-definition
-CFLAGS += -Wmissing-declarations
-CFLAGS += -Wmissing-include-dirs
-CFLAGS += -Wstrict-aliasing=2
-CFLAGS += -Wstrict-aliasing=3
-CFLAGS += -Wunsafe-loop-optimizations
-CFLAGS += -Winvalid-pch
-#CFLAGS += -Waddress (-Wall does this)
-CFLAGS += -Wvolatile-register-var
-CFLAGS += -Wmissing-format-attribute
-CFLAGS += -Wstack-protector
-#CFLAGS += -Werror (OBS build might have different compiler)
-CFLAGS += -Wno-declaration-after-statement
+override CFLAGS += -Wall
+override CFLAGS += -Wextra
+override CFLAGS += -Wpointer-arith
+override CFLAGS += -Wundef
+override CFLAGS += -Wcast-align
+override CFLAGS += -Wshadow
+override CFLAGS += -Wbad-function-cast
+override CFLAGS += -Wwrite-strings
+override CFLAGS += -Wsign-compare
+override CFLAGS += -Waggregate-return
+override CFLAGS += -Wmissing-noreturn
+override CFLAGS += -Wnested-externs
+#override CFLAGS += -Wchar-subscripts (-Wall does this)
+override CFLAGS += -Wmissing-prototypes
+override CFLAGS += -Wformat-security
+override CFLAGS += -Wformat=2
......@@ -124,19 +117,23 @@ index aaef621..0042d37 100644
+override CFLAGS += -Wold-style-definition
+override CFLAGS += -Wmissing-declarations
+override CFLAGS += -Wmissing-include-dirs
+override CFLAGS += -Wstrict-aliasing=2
+override CFLAGS += -Wstrict-aliasing=3
+override CFLAGS += -Wunsafe-loop-optimizations
+override CFLAGS += -Winvalid-pch
+#override CFLAGS += -Waddress (-Wall does this)
#CFLAGS += -Waddress (-Wall does this)
-CFLAGS += -Wvolatile-register-var
-CFLAGS += -Wmissing-format-attribute
-CFLAGS += -Wstack-protector
+override CFLAGS += -Wvolatile-register-var
+override CFLAGS += -Wmissing-format-attribute
+override CFLAGS += -Wstack-protector
+#override CFLAGS += -Werror (OBS build might have different compiler)
#CFLAGS += -Werror (OBS build might have different compiler)
-CFLAGS += -Wno-declaration-after-statement
+override CFLAGS += -Wno-declaration-after-statement
# Linker
LDLIBS += -Wl,--as-needed
@@ -260,7 +260,7 @@ MCE_PKG_NAMES += dbus-1
@@ -273,7 +273,7 @@ MCE_PKG_NAMES += dbus-1
MCE_PKG_NAMES += dbus-glib-1
MCE_PKG_NAMES += dsme
MCE_PKG_NAMES += libiphb
......@@ -145,7 +142,7 @@ index aaef621..0042d37 100644
MCE_PKG_NAMES += libngf0
MCE_PKG_CFLAGS := $(shell $(PKG_CONFIG) --cflags $(MCE_PKG_NAMES))
@@ -305,7 +305,7 @@ ifeq ($(strip $(ENABLE_WAKELOCKS)),y)
@@ -320,7 +320,7 @@ ifeq ($(strip $(ENABLE_WAKELOCKS)),y)
MCE_CORE += libwakelock.c
endif
......@@ -154,7 +151,7 @@ index aaef621..0042d37 100644
mce : LDLIBS += $(MCE_LDLIBS)
ifeq ($(ENABLE_HYBRIS),y)
mce : LDLIBS += -ldl
@@ -336,7 +336,7 @@ MODULE_LDLIBS += $(MODULE_PKG_LDLIBS)
@@ -351,7 +351,7 @@ MODULE_LDLIBS += $(MODULE_PKG_LDLIBS)
%.pic.o : %.c
$(CC) -c -o $@ $< -fPIC $(CPPFLAGS) $(CFLAGS)
......@@ -163,7 +160,7 @@ index aaef621..0042d37 100644
$(MODULE_DIR)/%.so : LDLIBS += $(MODULE_LDLIBS)
$(MODULE_DIR)/%.so : $(MODULE_DIR)/%.pic.o
$(CC) -shared -o $@ $^ $(LDFLAGS) $(LDLIBS)
@@ -355,11 +355,11 @@ TOOLS_PKG_LDLIBS := $(shell $(PKG_CONFIG) --libs $(TOOLS_PKG_NAMES))
@@ -370,11 +370,11 @@ TOOLS_PKG_LDLIBS := $(shell $(PKG_CONFIG) --libs $(TOOLS_PKG_NAMES))
TOOLS_CFLAGS += $(TOOLS_PKG_CFLAGS)
TOOLS_LDLIBS += $(TOOLS_PKG_LDLIBS)
......@@ -175,9 +172,9 @@ index aaef621..0042d37 100644
-$(TOOLDIR)/evdev_trace : CFLAGS += $(TOOLS_CFLAGS)
+$(TOOLDIR)/evdev_trace : override CFLAGS += $(TOOLS_CFLAGS)
$(TOOLDIR)/evdev_trace : LDLIBS += $(TOOLS_LDLIBS)
$(TOOLDIR)/evdev_trace : $(TOOLDIR)/evdev_trace.o evdev.o
$(TOOLDIR)/evdev_trace : $(TOOLDIR)/evdev_trace.o evdev.o $(TOOLDIR)/fileusers.o
@@ -382,7 +382,7 @@ UTESTS_LDLIBS += $(UTESTS_PKG_LDLIBS)
@@ -397,7 +397,7 @@ UTESTS_LDLIBS += $(UTESTS_PKG_LDLIBS)
UTESTS_CFLAGS += -fdata-sections -ffunction-sections
UTESTS_LDLIBS += -Wl,--gc-sections
......@@ -187,5 +184,5 @@ index aaef621..0042d37 100644
$(UTESTDIR)/% : LDLIBS += $(foreach fn_sym,$(LINK_STUBS),\
-Wl,--defsym=$(fn_sym)=stub__$(fn_sym))
--
2.9.3
2.14.3
From 985c1ffdbdee08f20270c66bd2a23fd460e144a4 Mon Sep 17 00:00:00 2001
From 1ee33335f424d9e4994feab6f0d5cf1cfdbe9853 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Fri, 5 May 2017 14:26:01 +0200
Date: Tue, 20 Feb 2018 15:07:14 +0100
Subject: [PATCH] Display: Sets default brightness to 100%
---
builtin-gconf.c | 2 +-
modules/display.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin-gconf.c b/builtin-gconf.c
index 4078518..4a9a953 100644
--- a/builtin-gconf.c
+++ b/builtin-gconf.c
@@ -1153,7 +1153,7 @@ static const setting_t gconf_defaults[] =
{
.key = MCE_GCONF_DISPLAY_BRIGHTNESS,
.type = "i",
- .def = "3", // Note: Legacy value, migrated at mce startup
+ .def = "5", // Note: Legacy value, migrated at mce startup
},
{
.key = MCE_GCONF_DISPLAY_BRIGHTNESS_LEVEL_SIZE,
diff --git a/modules/display.h b/modules/display.h
index 03dadb1..641162c 100644
--- a/modules/display.h
+++ b/modules/display.h
@@ -225,7 +225,7 @@
* will migrate old-style values to [1,100] range on startup.
*/
# define MCE_SETTING_DISPLAY_BRIGHTNESS MCE_SETTING_DISPLAY_PATH "/display_brightness"
-# define MCE_DEFAULT_DISPLAY_BRIGHTNESS 3 // uses legacy [1,5] range = 60%
+# define MCE_DEFAULT_DISPLAY_BRIGHTNESS 5 // uses legacy [1,5] range = 60%
/** Default brightness fade duration [ms]
*
--
2.11.0
2.14.3
From 563e94abab883a78a95289b08552685dfa4357cd Mon Sep 17 00:00:00 2001
From 43bc18a6b600ef405f1fe2aaa7cdae3f8fca70a0 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Mon, 8 May 2017 19:57:28 +0200
Date: Tue, 20 Feb 2018 15:26:12 +0100
Subject: [PATCH] Display: Sets dimming timeout to 10 sec and blanking timeout
to 5 sec
---
modules/display.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
modules/display.h | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/modules/display.h b/modules/display.h
index 458eb09..d14f234 100644
index 03dadb1..b765dc3 100644
--- a/modules/display.h
+++ b/modules/display.h
@@ -275,10 +275,10 @@ typedef enum
#define DEFAULT_DISP_BRIGHTNESS_STEP_SIZE 1
/** Default value for MCE_GCONF_DISPLAY_BLANK_TIMEOUT setting */
-#define DEFAULT_BLANK_TIMEOUT 3
+#define DEFAULT_BLANK_TIMEOUT 5
/** Default value for MCE_GCONF_DISPLAY_BLANK_FROM_LOCKSCREEN_TIMEOUT setting */
-#define DEFAULT_BLANK_FROM_LOCKSCREEN_TIMEOUT 10
+#define DEFAULT_BLANK_FROM_LOCKSCREEN_TIMEOUT 5
/** Default value for MCE_GCONF_DISPLAY_BLANK_FROM_LPM_ON_TIMEOUT setting */
#define DEFAULT_BLANK_FROM_LPM_ON_TIMEOUT 5
@@ -293,7 +293,7 @@ typedef enum
#define DEFAULT_ADAPTIVE_DIMMING_THRESHOLD 3000 /* 3 seconds */
/** Default dim timeout, in seconds */
-#define DEFAULT_DIM_TIMEOUT 30 /* 30 seconds */
+#define DEFAULT_DIM_TIMEOUT 10 /* 10 seconds */
/** Minimum blanking delay after bootup, in seconds */
#define AFTERBOOT_BLANKING_TIMEOUT 30
@@ -379,7 +379,7 @@ enum
#define DEFAULT_DISPLAY_OFF_OVERRIDE DISPLAY_OFF_OVERRIDE_DISABLED
/** Default value for MCE_GCONF_DISPLAY_DIM_TIMEOUT_LIST setting */
-#define DEFAULT_DISPLAY_DIM_TIMEOUT_LIST 15,30,60,120,600
+#define DEFAULT_DISPLAY_DIM_TIMEOUT_LIST 10,30,60,120,600
/** Use Orientation sensor GConf setting */
# define MCE_GCONF_ORIENTATION_SENSOR_ENABLED MCE_GCONF_DISPLAY_PATH"/orientation_sensor_enabled"
@@ -274,11 +274,11 @@
* Hint for settings UI. Also used for adaptive dimming within mce.
*/
# define MCE_SETTING_DISPLAY_DIM_TIMEOUT_LIST MCE_SETTING_DISPLAY_PATH "/possible_display_dim_timeouts"
-# define MCE_DEFAULT_DISPLAY_DIM_TIMEOUT_LIST 15,30,60,120,600
+# define MCE_DEFAULT_DISPLAY_DIM_TIMEOUT_LIST 10,30,60,120,600
/** Display dimming delay [s] */
# define MCE_SETTING_DISPLAY_DIM_TIMEOUT MCE_SETTING_DISPLAY_PATH "/display_dim_timeout"
-# define MCE_DEFAULT_DISPLAY_DIM_TIMEOUT 30
+# define MCE_DEFAULT_DISPLAY_DIM_TIMEOUT 10
/** Display dimming delay when slidable hw keyboard is open [s]
*
@@ -353,15 +353,15 @@
* Hint for settings UI. Not used by MCE itself.
*/
# define MCE_SETTING_DISPLAY_BLANK_TIMEOUT_LIST MCE_SETTING_DISPLAY_PATH "/possible_display_blank_timeouts"
-# define MCE_DEFAULT_DISPLAY_BLANK_TIMEOUT_LIST 3,10,15
+# define MCE_DEFAULT_DISPLAY_BLANK_TIMEOUT_LIST 5,10,15
/** Display blanking delay from dimmed state [s] */
# define MCE_SETTING_DISPLAY_BLANK_TIMEOUT MCE_SETTING_DISPLAY_PATH "/display_blank_timeout"
-# define MCE_DEFAULT_DISPLAY_BLANK_TIMEOUT 3
+# define MCE_DEFAULT_DISPLAY_BLANK_TIMEOUT 5
/** Display blanking delay from lockscreen [s] */
# define MCE_SETTING_DISPLAY_BLANK_FROM_LOCKSCREEN_TIMEOUT MCE_SETTING_DISPLAY_PATH "/display_blank_from_locksreen_timeout"
-# define MCE_DEFAULT_DISPLAY_BLANK_FROM_LOCKSCREEN_TIMEOUT 10
+# define MCE_DEFAULT_DISPLAY_BLANK_FROM_LOCKSCREEN_TIMEOUT 5
/** Display blanking delay from lpm-on state [s] */
# define MCE_SETTING_DISPLAY_BLANK_FROM_LPM_ON_TIMEOUT MCE_SETTING_DISPLAY_PATH "/display_blank_from_lpm_on_timeout"
--
2.11.0
2.14.3
From f71fd191356fa0a907d1a416a6cc306d56e68697 Mon Sep 17 00:00:00 2001
From 977c36ad714032c9ce0c6a84dfd93cf09dfcc9bf Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 29 Oct 2017 16:01:41 +0100
Date: Wed, 21 Feb 2018 15:54:02 +0100
Subject: [PATCH] Keep screen on by default on emulator
---
builtin-gconf.c | 2 +-
modules/display.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin-gconf.c b/builtin-gconf.c
index 4078518..c24d86b 100644
--- a/builtin-gconf.c
+++ b/builtin-gconf.c
@@ -1325,7 +1325,7 @@ static const setting_t gconf_defaults[] =
// MCE_GCONF_BLANKING_INHIBIT_MODE @ modules/display.h
.key = "/system/osso/dsm/display/inhibit_blank_mode",
.type = "i",
- .def = "0",
+ .def = "3",
},
{
.key = MCE_GCONF_KBD_SLIDE_INHIBIT,
diff --git a/modules/display.h b/modules/display.h
index 03dadb1..3656b4e 100644
--- a/modules/display.h
+++ b/modules/display.h
@@ -414,7 +414,7 @@ typedef enum {
* logic without modifying the timeout values.
*/
# define MCE_SETTING_BLANKING_INHIBIT_MODE MCE_SETTING_DISPLAY_PATH "/inhibit_blank_mode"
-# define MCE_DEFAULT_BLANKING_INHIBIT_MODE 0 // = INHIBIT_OFF
+# define MCE_DEFAULT_BLANKING_INHIBIT_MODE 1 // = INHIBIT_ON
/** Kbd slide inhibit type */
typedef enum {
--
2.14.3
......@@ -10,7 +10,7 @@ SRC_URI = "git://git.merproject.org/mer-core/mce.git;protocol=https \
file://0004-event-input-Double-tap-emulation-Adapts-the-state-ma.patch \
file://mce.service"
SRC_URI_append_qemux86 = " file://0005-Keep-screen-on-by-default-on-emulator.patch"
SRCREV = "ad535db76b7443febaf4f97328eb1968a3f1d8cc"
SRCREV = "0510206026438b9de0d6a0f4d46e0c5674d37398"
PR = "r1"
PV = "+git${SRCPV}"
S = "${WORKDIR}/git"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment