Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
a407fec7
Commit
a407fec7
authored
Dec 13, 2015
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Upgrade lipstick and fixes API break with Qt5.5
parent
df501a7a
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
140 additions
and
37 deletions
+140
-37
0001-Disables-tests-and-doc-and-fixes-build.patch
...ipstick/0001-Disables-tests-and-doc-and-fixes-build.patch
+137
-31
lipstick_git.bb
recipes-nemomobile/lipstick/lipstick_git.bb
+3
-6
No files found.
recipes-nemomobile/lipstick/lipstick/0001-Disables-tests-and-doc-and-fixes-build.patch
View file @
a407fec7
From
e9700fddec7f2697042d94b71cf4c7a919ab0217
Mon Sep 17 00:00:00 2001
From
dc0207413df0cf90f96d37d08a84d9f0110e63e8
Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
From: Florent Revest <revestflo@gmail.com>
Date:
Tue, 14 Jul 2015 17:31:11 +02
00
Date:
Sun, 13 Dec 2015 13:45:25 +01
00
Subject: [PATCH] Disables tests and doc and fixes build
Subject: [PATCH] Disables tests and doc and fixes build
---
---
lipstick.pro | 4 ++--
lipstick.pro | 2 +-
src/lipstickglobal.h | 2 ++
src/compositor/hwcrenderstage.h | 3 ++-
src/compositor/lipstickcompositor.cpp | 9 ++++-----
src/compositor/lipstickcompositor.h | 3 ++-
src/compositor/lipstickcompositorwindow.cpp | 2 +-
src/compositor/windowmodel.cpp | 2 +-
src/notifications/lipsticknotification.cpp | 1 +
src/src.pro | 2 +-
src/src.pro | 2 +-
3 files changed, 5 insertions(+), 3
deletions(-)
8 files changed, 13 insertions(+), 11
deletions(-)
diff --git a/lipstick.pro b/lipstick.pro
diff --git a/lipstick.pro b/lipstick.pro
index 78ee362..
ca7971
1 100644
index 78ee362..
28f072
1 100644
--- a/lipstick.pro
--- a/lipstick.pro
+++ b/lipstick.pro
+++ b/lipstick.pro
@@ -1,
9 +1,9
@@
@@ -1,
5 +1,5
@@
TEMPLATE = subdirs
TEMPLATE = subdirs
-SUBDIRS += src plugin tools tests doc
-SUBDIRS += src plugin tools tests doc
+SUBDIRS += src plugin tools
+SUBDIRS += src plugin tools
plugin.depends = src
plugin.depends = src
tools.depends = src
tools.depends = src
-tests.depends = src
diff --git a/src/compositor/hwcrenderstage.h b/src/compositor/hwcrenderstage.h
+
index e535f81..cbd1f09 100644
--- a/src/compositor/hwcrenderstage.h
QMAKE_CLEAN += \
+++ b/src/compositor/hwcrenderstage.h
build-stamp \
@@ -17,6 +17,7 @@
diff --git a/src/lipstickglobal.h b/src/lipstickglobal.h
#define HWCRENDERSTAGE
index 01ffed0..be236bf 100644
--- a/src/lipstickglobal.h
#include <private/qquickwindow_p.h>
+++ b/src/lipstickglobal.h
+#include <private/qsgrenderer_p.h>
@@ -18,6 +18,8 @@
#define LIPSTICKGLOBAL_H
Q_DECLARE_LOGGING_CATEGORY(LIPSTICK_LOG_HWC)
#include <QtGlobal>
@@ -130,4 +131,4 @@
private:
+#include <QDebug>
static bool m_hwcEnabled;
+#include <QGuiApplication>
};
#if defined(LIPSTICK_BUILD_LIBRARY)
-#endif // HWCRENDERSTAGE
#define LIPSTICK_EXPORT Q_DECL_EXPORT
\
No newline at end of file
+#endif // HWCRENDERSTAGE
diff --git a/src/compositor/lipstickcompositor.cpp b/src/compositor/lipstickcompositor.cpp
index bf2f0e9..57127f5 100644
--- a/src/compositor/lipstickcompositor.cpp
+++ b/src/compositor/lipstickcompositor.cpp
@@ -41,8 +41,7 @@
LipstickCompositor *LipstickCompositor::m_instance = 0;
LipstickCompositor::LipstickCompositor()
- : QWaylandQuickCompositor(this, 0, (QWaylandCompositor::ExtensionFlags)QWaylandCompositor::DefaultExtensions & ~QWaylandCompositor::QtKeyExtension)
- , m_totalWindowCount(0)
+ : m_totalWindowCount(0)
, m_nextWindowId(1)
, m_homeActive(true)
, m_shaderEffect(0)
@@ -183,7 +182,7 @@
void LipstickCompositor::surfaceCreated(QWaylandSurface *surface)
connect(surface, &QWaylandSurface::redraw, this, &LipstickCompositor::surfaceCommitted);
}
-bool LipstickCompositor::openUrl(WaylandClient *client, const QUrl &url)
+bool LipstickCompositor::openUrl(QWaylandClient *client, const QUrl &url)
{
Q_UNUSED(client)
return openUrl(url);
@@ -286,7 +285,7 @@
int LipstickCompositor::windowIdForLink(QWaylandSurface *s, uint link) const
QWaylandSurface *windowSurface = iter.value()->surface();
if (windowSurface && windowSurface->client() && s->client() &&
- windowSurface->processId() == s->processId() &&
+ windowSurface->client()->processId() == s->client()->processId() &&
windowSurface->windowProperties().value("WINID", uint(0)).toUInt() == link)
return iter.value()->windowId();
}
@@ -357,7 +356,7 @@
void LipstickCompositor::setTopmostWindowId(int id)
QWaylandSurface *surface = surfaceForId(m_topmostWindowId);
if (surface)
- pid = surface->processId();
+ pid = surface->client()->processId();
if (m_topmostWindowProcessId != pid) {
m_topmostWindowProcessId = pid;
diff --git a/src/compositor/lipstickcompositor.h b/src/compositor/lipstickcompositor.h
index e3db6b1..33be214 100644
--- a/src/compositor/lipstickcompositor.h
+++ b/src/compositor/lipstickcompositor.h
@@ -21,6 +21,7 @@
#include <QQmlParserStatus>
#include <QWaylandQuickCompositor>
#include <QWaylandSurfaceItem>
+#include <QWaylandClient>
#include <QPointer>
#include <QTimer>
#include <MGConfItem>
@@ -64,7 +65,7 @@
public:
void classBegin() Q_DECL_OVERRIDE;
void componentComplete() Q_DECL_OVERRIDE;
void surfaceCreated(QWaylandSurface *surface) Q_DECL_OVERRIDE;
- bool openUrl(WaylandClient *client, const QUrl &url) Q_DECL_OVERRIDE;
+ bool openUrl(QWaylandClient *client, const QUrl &url) Q_DECL_OVERRIDE;
void retainedSelectionReceived(QMimeData *mimeData) Q_DECL_OVERRIDE;
int windowCount() const;
diff --git a/src/compositor/lipstickcompositorwindow.cpp b/src/compositor/lipstickcompositorwindow.cpp
index bab4c42..a9c21ca 100644
--- a/src/compositor/lipstickcompositorwindow.cpp
+++ b/src/compositor/lipstickcompositorwindow.cpp
@@ -77,7 +77,7 @@
int LipstickCompositorWindow::windowId() const
qint64 LipstickCompositorWindow::processId() const
{
if (surface())
- return surface()->processId();
+ return surface()->client()->processId();
else return 0;
}
diff --git a/src/compositor/windowmodel.cpp b/src/compositor/windowmodel.cpp
index 7ecd4d4..03c5b82 100644
--- a/src/compositor/windowmodel.cpp
+++ b/src/compositor/windowmodel.cpp
@@ -68,7 +68,7 @@
QVariant WindowModel::data(const QModelIndex &index, int role) const
return m_items.at(idx);
} else if (role == Qt::UserRole + 2) {
QWaylandSurface *s = c->surfaceForId(m_items.at(idx));
- return s?s->processId():0;
+ return s?s->client()->processId():0;
} else if (role == Qt::UserRole + 3) {
LipstickCompositorWindow *w = static_cast<LipstickCompositorWindow *>(c->windowForId(m_items.at(idx)));
return w->title();
diff --git a/src/notifications/lipsticknotification.cpp b/src/notifications/lipsticknotification.cpp
index 3b18a13..af6d607 100644
--- a/src/notifications/lipsticknotification.cpp
+++ b/src/notifications/lipsticknotification.cpp
@@ -18,6 +18,7 @@
#include <QDBusArgument>
#include <QtDebug>
+#include <QDataStream>
LipstickNotification::LipstickNotification(const QString &appName, uint replacesId, const QString &appIcon, const QString &summary, const QString &body, const QStringList &actions, const QVariantHash &hints, int expireTimeout, QObject *parent) :
QObject(parent),
diff --git a/src/src.pro b/src/src.pro
diff --git a/src/src.pro b/src/src.pro
index
f3affe8..9f95a75
100644
index
5e66ecb..f8d4ff1
100644
--- a/src/src.pro
--- a/src/src.pro
+++ b/src/src.pro
+++ b/src/src.pro
@@ -1
15,7 +115
,7 @@
SOURCES += \
@@ -1
39,7 +139
,7 @@
SOURCES += \
CONFIG += link_pkgconfig mobility qt warn_on depend_includepath qmake_cache target_qt
CONFIG += link_pkgconfig mobility qt warn_on depend_includepath qmake_cache target_qt
CONFIG -= link_prl
CONFIG -= link_prl
-PKGCONFIG += mlite5 mce
dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 qmsystem2-qt5 Qt5SystemInfo libsystemd-daemon
-PKGCONFIG += mlite5 mce
keepalive dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 Qt5SystemInfo libsystemd-daemon contextkit-statefs dsme_dbus_if thermalmanager_dbus_if usb-moded-qt5
+PKGCONFIG += mlite5 mce
dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 qmsystem2-qt5 Qt5SystemInfo libsystemd
+PKGCONFIG += mlite5 mce
keepalive dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 Qt5SystemInfo libsystemd contextkit-statefs dsme_dbus_if thermalmanager_dbus_if usb-moded-qt5 egl
LIBS += -lrt
LIBS += -lrt
--
--
2.
1.4
2.
6.2
recipes-nemomobile/lipstick/lipstick_git.bb
View file @
a407fec7
...
@@ -3,16 +3,13 @@ HOMEPAGE = "https://git.merproject.org/mer-core/lipstick"
...
@@ -3,16 +3,13 @@ HOMEPAGE = "https://git.merproject.org/mer-core/lipstick"
LICENSE = "LGPL-2.1+"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = "git://git.merproject.org/mer-core/lipstick.git;protocol=https \
SRC_URI = "git://git.merproject.org/mer-core/lipstick.git;protocol=https"
file://0001-Disables-tests-and-doc-and-fixes-build.patch"
SRCREV = "d393a948d2d7d179dbe5dedf3ae68543e655507a"
SRC_URI[md5sum] = "d1b7dc2ee09b51192b14083292135c69"
SRC_URI[sha256sum] = "aa8049c9d49bb035f526d19a2bfb7d8e5b78c810946b10dcbd1d02c7a88520e4"
SRCREV = "d62073e39be884350d81977da1beaceaafb46164"
PR = "r1"
PR = "r1"
PV = "+git${SRCREV}"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
S = "${WORKDIR}/git"
DEPENDS += "qtbase qtsensors qtquick1 qtwayland mlite dbus dbus-glib libresourceqt qtsystems libngf-qt statefs-qt mce usb-moded-qt5 systemd wayland qt5-qpa-hwcomposer-plugin qmsystem qttools-native"
DEPENDS += "qtbase qtsensors qtquick1 qtwayland mlite dbus dbus-glib libresourceqt qtsystems libngf-qt statefs-qt mce usb-moded-qt5 systemd wayland qt5-qpa-hwcomposer-plugin qmsystem
nemo-keepalive
qttools-native"
RDEPENDS_${PN} += "qt5-qpa-hwcomposer-plugin"
RDEPENDS_${PN} += "qt5-qpa-hwcomposer-plugin"
# qt5-qpa-hwcomposer-plugin isn't detected to be needed at runtime by OpenEmbedded
# qt5-qpa-hwcomposer-plugin isn't detected to be needed at runtime by OpenEmbedded
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment