Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
b23b361b
Commit
b23b361b
authored
Oct 09, 2016
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Adds an initial version of buteo-synfw and buteo-mtp
parent
0392a727
Changes
3
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
174 additions
and
0 deletions
+174
-0
0001-Remove-dependency-to-SSU.patch
...obile/buteo/buteo-mtp/0001-Remove-dependency-to-SSU.patch
+129
-0
buteo-mtp_git.bb
recipes-nemomobile/buteo/buteo-mtp_git.bb
+22
-0
buteo-syncfw_git.bb
recipes-nemomobile/buteo/buteo-syncfw_git.bb
+23
-0
No files found.
recipes-nemomobile/buteo/buteo-mtp/0001-Remove-dependency-to-SSU.patch
0 → 100644
View file @
b23b361b
From d493df1cd36949f688681f894256bdf883951986 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 9 Oct 2016 19:01:52 +0200
Subject: [PATCH] Remove dependency to SSU
---
libmeegomtp.pro | 30 ----------------------
mts/mts.pro | 2 --
mts/platform/deviceinfo/deviceinfoprovider.cpp | 7 +----
.../storage/fsstorageplugin/fsstorageplugin.pro | 2 +-
4 files changed, 2 insertions(+), 39 deletions(-)
diff --git a/libmeegomtp.pro b/libmeegomtp.pro
index db788fb..84136ba 100644
--- a/libmeegomtp.pro
+++ b/libmeegomtp.pro
@@ -3,33 +3,14 @@
TEMPLATE = subdirs
mts.subdir = mts
mts.target = sub-mts
-test.subdir = test
-test.target = sub-test
-test.depends = sub-mts
-
mtpserver.subdir = mtpserver
mtpserver.target = sub-mtpserver
mtpserver.depends = sub-mts
-mts_storage_tests.subdir = mts/platform/storage/unittests
-mts_storage_tests.depends= sub-mts
-
mts_fsstorage_plugin.subdir = mts/platform/storage/fsstorageplugin
mts_fsstorage_plugin.target = sub-mts-fsstorage-plugin
mts_fsstorage_plugin.depends = sub-mts
-mts_fsstorage_tests.subdir = mts/platform/storage/fsstorageplugin/unittests
-mts_fsstorage_tests.target = sub-mts-fsstorage-tests
-mts_fsstorage_tests.depends = sub-mts
-
-mts_deviceinfo_tests.subdir = mts/platform/deviceinfo/unittests
-mts_deviceinfo_tests.target = sub-mts-deviceinfo-tests
-mts_deviceinfo_tests.depends = sub-mts
-
-mts_protocol_tests.subdir = mts/protocol/unittests
-mts_protocol_tests.target = sub-mts-protocol-tests
-mts_protocol_tests.depends = sub-mts
-
service.subdir = service
service.target = sub-service
service.depends = sub-mts
@@ -39,17 +20,6 @@
systemd.target = sub-systemd
SUBDIRS += \
mts \
- test \
mtpserver \
- mts_storage_tests \
- mts_fsstorage_plugin \
- mts_fsstorage_tests \
- mts_deviceinfo_tests \
- mts_protocol_tests \
service \
systemd
-
-# install additional files for the CI Integration tests
-citests.path = /opt/tests/buteo-mtp/test-definition/
-citests.files = tests.xml
-INSTALLS += citests
diff --git a/mts/mts.pro b/mts/mts.pro
index 765dd08..09268dd 100644
--- a/mts/mts.pro
+++ b/mts/mts.pro
@@ -1,8 +1,6 @@
QT += xml dbus
QT -= gui
-LIBS += -lssu
-
CONFIG += link_pkgconfig debug
equals(QT_MAJOR_VERSION, 4): {
diff --git a/mts/platform/deviceinfo/deviceinfoprovider.cpp b/mts/platform/deviceinfo/deviceinfoprovider.cpp
index dd0d0d3..cbbfbc0 100644
--- a/mts/platform/deviceinfo/deviceinfoprovider.cpp
+++ b/mts/platform/deviceinfo/deviceinfoprovider.cpp
@@ -32,7 +32,6 @@
#include "deviceinfoprovider.h"
#include <QDeviceInfo>
#include <QTimer>
-#include <ssudeviceinfo.h>
#include <contextproperty.h>
#include "trace.h"
@@ -46,10 +45,6 @@
DeviceInfoProvider::DeviceInfoProvider():
{
QDeviceInfo di;
- SsuDeviceInfo ssuDeviceInfo;
-
- m_serialNo = ssuDeviceInfo.deviceUid();
-
m_deviceVersion = QString("%1 HW: %2").arg(di.version(QDeviceInfo::Os))
.arg(di.version(QDeviceInfo::Firmware));
@@ -68,7 +63,7 @@
DeviceInfoProvider::DeviceInfoProvider():
{
/* Query DeviceModel from SSU and use it to override the value of
* the friendly name -property defined in the XML configuration */
- QString deviceModel = ssuDeviceInfo.displayName(Ssu::DeviceModel);
+ QString deviceModel = "Asteroid";
MTP_LOG_INFO("Setting MTP friendly name to:" << deviceModel);
setDeviceFriendlyName(deviceModel);
}
diff --git a/mts/platform/storage/fsstorageplugin/fsstorageplugin.pro b/mts/platform/storage/fsstorageplugin/fsstorageplugin.pro
index 3f22edf..14467c3 100644
--- a/mts/platform/storage/fsstorageplugin/fsstorageplugin.pro
+++ b/mts/platform/storage/fsstorageplugin/fsstorageplugin.pro
@@ -44,7 +44,7 @@
SOURCES += fsstorageplugin.cpp \
storageitem.cpp
LIBPATH += ../../..
-LIBS += -lmeegomtp -lssu
+LIBS += -lmeegomtp
#install
target.path = /usr/lib/mtp
--
2.9.3
recipes-nemomobile/buteo/buteo-mtp_git.bb
0 → 100644
View file @
b23b361b
SUMMARY = "NemoMobile's MTP Stack"
HOMEPAGE = "https://git.merproject.org/mer-core/buteo-mtp"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://mtpserver/mtpserver.cpp;beginline=1;endline=30;md5=a2b2b5351d5e7a0b1f3b62af44e24404"
SRC_URI = "git://git.merproject.org/mer-core/buteo-mtp.git;protocol=https \
file://0001-Remove-dependency-to-SSU.patch"
SRCREV = "dd37c4f61e96bc25dd95d9661310e5326e31b593"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit qmake5
do_configure_prepend() {
sed -i "s@contextkit-statefs@contextkit-statefs contextsubscriber-1.0@" ${S}/mts/common.pri
sed -i "s@buteosyncfw5@buteosyncfw5 contextsubscriber-1.0@" ${S}/service/service.pro
sed -i "s@/bin/bash@/bin/sh@" ${S}/service/start-mtp.sh
}
DEPENDS += "buteo-syncfw"
FILES_${PN} += "/lib/systemd/system /usr/lib/systemd/user/ /usr/share/mtp/ /usr/lib/mtp/ /usr/lib/buteo-plugins-qt5"
recipes-nemomobile/buteo/buteo-syncfw_git.bb
0 → 100644
View file @
b23b361b
SUMMARY = "NemoMobile's Buteo Synchronization daemon"
HOMEPAGE = "https://git.merproject.org/mer-core/buteo-syncfw"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=93ae0a8ec7ecf7709c725bd232bbafc6"
SRC_URI = "git://git.merproject.org/mer-core/buteo-syncfw.git;protocol=https"
SRCREV = "ed05f850be3103231ff6cc3f78ae5b23bc504272"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit qmake5
EXTRA_QMAKEVARS_PRE += "CONFIG+=usb-moded DEFINES+=USE_KEEPALIVE"
do_configure_prepend() {
sed -i "/doc/d" ${S}/buteo-sync.pro
}
DEPENDS = "libaccounts-qt5 libsignon-qt5 qtsystems nemo-keepalive"
FILES_${PN} += "/usr/share/glib-2.0/schemas /usr/share/accounts/services/ /usr/lib/systemd"
FILES_${PN}-dev += "/usr/lib/libbuteosyncfw5.prl"
FILES_${PN}-dbg += "/opt/tests/"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment