Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
f374c729
Commit
f374c729
authored
Sep 17, 2015
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
qtwayland: fixes GLESv2 loading
parent
d3c5690c
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
34 additions
and
0 deletions
+34
-0
0001-Forces-GLES2-the-dirty-way.patch
...es-qt/qt5/qtwayland/0001-Forces-GLES2-the-dirty-way.patch
+32
-0
qtwayland_git.bbappend
recipes-qt/qt5/qtwayland_git.bbappend
+2
-0
No files found.
recipes-qt/qt5/qtwayland/0001-Forces-GLES2-the-dirty-way.patch
0 → 100644
View file @
f374c729
From b35bf98949aadd87a62c576b96ac243ee892ce78 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 17 Sep 2015 13:32:00 +0200
Subject: [PATCH] Forces GLES2 the dirty way
---
src/hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/src/hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp b/src/hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp
index 81c74a7..1c38350 100644
--- a/src/hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp
+++ b/src/hardwareintegration/client/wayland-egl/qwaylandglcontext.cpp
@@ -317,12 +317,9 @@
void QWaylandGLContext::updateGLFormat()
|| m_format.renderableType() == QSurfaceFormat::OpenGLES) {
const GLubyte *s = glGetString(GL_VERSION);
if (s) {
- QByteArray version = QByteArray(reinterpret_cast<const char *>(s));
- int major, minor;
- if (QPlatformOpenGLContext::parseOpenGLVersion(version, major, minor)) {
- m_format.setMajorVersion(major);
- m_format.setMinorVersion(minor);
- }
+ int major = 2, minor = 0;
+ m_format.setMajorVersion(major);
+ m_format.setMinorVersion(minor);
}
m_format.setProfile(QSurfaceFormat::NoProfile);
m_format.setOptions(QSurfaceFormat::FormatOptions());
--
2.5.1
recipes-qt/qt5/qtwayland_git.bbappend
0 → 100644
View file @
f374c729
FILESEXTRAPATHS_prepend := "${THISDIR}/qtwayland:"
SRC_URI += " file://0001-Forces-GLES2-the-dirty-way.patch "
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment