Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
ff348b3b
Commit
ff348b3b
authored
Jan 24, 2019
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
wayland: Remove wayland-egl which is distributed by libhybris
parent
1042df7c
Changes
3
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
606 additions
and
0 deletions
+606
-0
.0001-Remove-wayland-egl-which-is-distributed-by-libhybris.patch.swp
...e-wayland-egl-which-is-distributed-by-libhybris.patch.swp
+0
-0
0001-Remove-wayland-egl-which-is-distributed-by-libhybris.patch
...emove-wayland-egl-which-is-distributed-by-libhybris.patch
+605
-0
wayland_%.bbappend
recipes-graphics/wayland/wayland_%.bbappend
+1
-0
No files found.
recipes-graphics/wayland/wayland/.0001-Remove-wayland-egl-which-is-distributed-by-libhybris.patch.swp
0 → 100644
View file @
ff348b3b
File added
recipes-graphics/wayland/wayland/0001-Remove-wayland-egl-which-is-distributed-by-libhybris.patch
0 → 100644
View file @
ff348b3b
From 8c62497e62a7228cc5fc39090d0327b8908e8942 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 2 Dec 2018 18:37:25 +0100
Subject: [PATCH] Remove wayland-egl which is distributed by libhybris
---
Makefile.am | 21 +--
configure.ac | 2 -
egl/wayland-egl-abi-check.c | 235 ----------------------------------
egl/wayland-egl-backend.h | 67 ----------
egl/wayland-egl-backend.pc.in | 9 --
egl/wayland-egl-symbols-check | 51 --------
egl/wayland-egl.c | 104 ---------------
egl/wayland-egl.pc.in | 11 --
8 files changed, 1 insertion(+), 499 deletions(-)
delete mode 100644 egl/wayland-egl-abi-check.c
delete mode 100644 egl/wayland-egl-backend.h
delete mode 100644 egl/wayland-egl-backend.pc.in
delete mode 100755 egl/wayland-egl-symbols-check
delete mode 100644 egl/wayland-egl.c
delete mode 100644 egl/wayland-egl.pc.in
diff --git a/Makefile.am b/Makefile.am
index 697c517..9568674 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -146,20 +146,9 @@
libwayland_cursor_la_CFLAGS = \
-I$(top_srcdir)/src \
-DICONDIR=\"$(ICONDIR)\"
-lib_LTLIBRARIES += libwayland-egl.la
-
include_HEADERS += egl/wayland-egl.h
include_HEADERS += egl/wayland-egl-core.h
-libwayland_egl_la_SOURCES = egl/wayland-egl.c
-libwayland_egl_la_LDFLAGS = -version-info 1
-
-pkgconfig_DATA += egl/wayland-egl.pc
-
-## XXX: backend interface
-include_HEADERS += egl/wayland-egl-backend.h
-pkgconfig_DATA += egl/wayland-egl-backend.pc
-
built_test_programs = \
array-test \
client-test \
@@ -180,13 +169,7 @@
built_test_programs = \
message-test \
headers-test \
compositor-introspection-test \
- protocol-logger-test \
- wayland-egl-abi-check
-
-EXTRA_DIST += egl/wayland-egl-symbols-check
-
-check_PROGRAMS = wayland-egl-abi-check
-wayland_egl_abi_check_SOURCES = egl/wayland-egl-abi-check.c
+ protocol-logger-test
if ENABLE_CPP_TEST
built_test_programs += cpp-compile-test
@@ -196,13 +179,11 @@
AM_TESTS_ENVIRONMENT = \
export WAYLAND_SCANNER='$(top_builddir)/wayland-scanner' \
TEST_DATA_DIR='$(top_srcdir)/tests/data' \
TEST_OUTPUT_DIR='$(top_builddir)/tests/output' \
- WAYLAND_EGL_LIB='$(top_builddir)/.libs/libwayland-egl.so' \
SED=$(SED) \
NM='$(NM)' \
;
TESTS = $(built_test_programs) \
- egl/wayland-egl-symbols-check \
tests/scanner-test.sh
noinst_PROGRAMS = \
diff --git a/configure.ac b/configure.ac
index f05fba4..5a2d2c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -185,8 +185,6 @@
AC_CONFIG_FILES([Makefile
doc/publican/Makefile
doc/doxygen/Makefile
doc/man/Makefile
- egl/wayland-egl.pc
- egl/wayland-egl-backend.pc
src/wayland-server-uninstalled.pc
src/wayland-client-uninstalled.pc
src/wayland-scanner-uninstalled.pc
diff --git a/egl/wayland-egl-abi-check.c b/egl/wayland-egl-abi-check.c
deleted file mode 100644
index faa6b57..0000000
--- a/egl/wayland-egl-abi-check.c
+++ /dev/null
@@ -1,235 +0,0 @@
-/*
- * Copyright (c) 2017, NVIDIA CORPORATION. All rights reserved.
- *
- * Permission is hereby granted, free of charge, to any person obtaining a
- * copy of this software and associated documentation files (the "Software"),
- * to deal in the Software without restriction, including without limitation
- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
- * and/or sell copies of the Software, and to permit persons to whom the
- * Software is furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice shall be included in
- * all copies or substantial portions of the Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
- * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
- * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
- * DEALINGS IN THE SOFTWARE.
- */
-
-#include <stddef.h> /* offsetof */
-#include <stdio.h> /* printf */
-
-#include "wayland-egl-backend.h" /* Current struct wl_egl_window implementation */
-
-/*
- * Following are previous implementations of wl_egl_window.
- *
- * DO NOT EVER CHANGE!
- */
-
-/* From: 214fc6e850 - Benjamin Franzke : egl: Implement libwayland-egl */
-struct wl_egl_window_v0 {
- struct wl_surface *surface;
-
- int width;
- int height;
- int dx;
- int dy;
-
- int attached_width;
- int attached_height;
-};
-
-/* From: ca3ed3e024 - Ander Conselvan de Oliveira : egl/wayland: Don't invalidate drawable on swap buffers */
-struct wl_egl_window_v1 {
- struct wl_surface *surface;
-
- int width;
- int height;
- int dx;
- int dy;
-
- int attached_width;
- int attached_height;
-
- void *private;
- void (*resize_callback)(struct wl_egl_window *, void *);
-};
-
-/* From: 690ead4a13 - Stencel, Joanna : egl/wayland-egl: Fix for segfault in dri2_wl_destroy_surface. */
-#define WL_EGL_WINDOW_VERSION_v2 2
-struct wl_egl_window_v2 {
- struct wl_surface *surface;
-
- int width;
- int height;
- int dx;
- int dy;
-
- int attached_width;
- int attached_height;
-
- void *private;
- void (*resize_callback)(struct wl_egl_window *, void *);
- void (*destroy_window_callback)(void *);
-};
-
-/* From: 2d5d61bc49 - Miguel A. Vico : wayland-egl: Make wl_egl_window a versioned struct */
-#define WL_EGL_WINDOW_VERSION_v3 3
-struct wl_egl_window_v3 {
- const intptr_t version;
-
- int width;
- int height;
- int dx;
- int dy;
-
- int attached_width;
- int attached_height;
-
- void *driver_private;
- void (*resize_callback)(struct wl_egl_window *, void *);
- void (*destroy_window_callback)(void *);
-
- struct wl_surface *surface;
-};
-
-
-/* This program checks we keep a backwards-compatible struct wl_egl_window
- * definition whenever it is modified in wayland-egl-backend.h.
- *
- * The previous definition should be added above as a new struct
- * wl_egl_window_vN, and the appropriate checks should be added below
- */
-
-#define MEMBER_SIZE(type, member) sizeof(((type *)0)->member)
-
-#define CHECK_RENAMED_MEMBER(a_ver, b_ver, a_member, b_member) \
- do { \
- if (offsetof(struct wl_egl_window ## a_ver, a_member) != \
- offsetof(struct wl_egl_window ## b_ver, b_member)) { \
- printf("Backards incompatible change detected!\n " \
- "offsetof(struct wl_egl_window" #a_ver "::" #a_member ") != " \
- "offsetof(struct wl_egl_window" #b_ver "::" #b_member ")\n"); \
- return 1; \
- } \
- \
- if (MEMBER_SIZE(struct wl_egl_window ## a_ver, a_member) != \
- MEMBER_SIZE(struct wl_egl_window ## b_ver, b_member)) { \
- printf("Backards incompatible change detected!\n " \
- "MEMBER_SIZE(struct wl_egl_window" #a_ver "::" #a_member ") != " \
- "MEMBER_SIZE(struct wl_egl_window" #b_ver "::" #b_member ")\n"); \
- return 1; \
- } \
- } while (0)
-
-#define CHECK_MEMBER(a_ver, b_ver, member) CHECK_RENAMED_MEMBER(a_ver, b_ver, member, member)
-#define CHECK_MEMBER_CURRENT(a_ver, member) CHECK_MEMBER(a_ver,, member)
-
-#define CHECK_SIZE(a_ver, b_ver) \
- do { \
- if (sizeof(struct wl_egl_window ## a_ver) > \
- sizeof(struct wl_egl_window ## b_ver)) { \
- printf("Backards incompatible change detected!\n " \
- "sizeof(struct wl_egl_window" #a_ver ") > " \
- "sizeof(struct wl_egl_window" #b_ver ")\n"); \
- return 1; \
- } \
- } while (0)
-
-#define CHECK_SIZE_CURRENT(a_ver) \
- do { \
- if (sizeof(struct wl_egl_window ## a_ver) != \
- sizeof(struct wl_egl_window)) { \
- printf("Backards incompatible change detected!\n " \
- "sizeof(struct wl_egl_window" #a_ver ") != " \
- "sizeof(struct wl_egl_window)\n"); \
- return 1; \
- } \
- } while (0)
-
-#define CHECK_VERSION(a_ver, b_ver) \
- do { \
- if ((WL_EGL_WINDOW_VERSION ## a_ver) >= \
- (WL_EGL_WINDOW_VERSION ## b_ver)) { \
- printf("Backards incompatible change detected!\n " \
- "WL_EGL_WINDOW_VERSION" #a_ver " >= " \
- "WL_EGL_WINDOW_VERSION" #b_ver "\n"); \
- return 1; \
- } \
- } while (0)
-
-#define CHECK_VERSION_CURRENT(a_ver) \
- do { \
- if ((WL_EGL_WINDOW_VERSION ## a_ver) != \
- (WL_EGL_WINDOW_VERSION)) { \
- printf("Backards incompatible change detected!\n " \
- "WL_EGL_WINDOW_VERSION" #a_ver " != " \
- "WL_EGL_WINDOW_VERSION\n"); \
- return 1; \
- } \
- } while (0)
-
-int main(int argc, char **argv)
-{
- /* Check wl_egl_window_v1 ABI against wl_egl_window_v0 */
- CHECK_MEMBER(_v0, _v1, surface);
- CHECK_MEMBER(_v0, _v1, width);
- CHECK_MEMBER(_v0, _v1, height);
- CHECK_MEMBER(_v0, _v1, dx);
- CHECK_MEMBER(_v0, _v1, dy);
- CHECK_MEMBER(_v0, _v1, attached_width);
- CHECK_MEMBER(_v0, _v1, attached_height);
-
- CHECK_SIZE(_v0, _v1);
-
- /* Check wl_egl_window_v2 ABI against wl_egl_window_v1 */
- CHECK_MEMBER(_v1, _v2, surface);
- CHECK_MEMBER(_v1, _v2, width);
- CHECK_MEMBER(_v1, _v2, height);
- CHECK_MEMBER(_v1, _v2, dx);
- CHECK_MEMBER(_v1, _v2, dy);
- CHECK_MEMBER(_v1, _v2, attached_width);
- CHECK_MEMBER(_v1, _v2, attached_height);
- CHECK_MEMBER(_v1, _v2, private);
- CHECK_MEMBER(_v1, _v2, resize_callback);
-
- CHECK_SIZE(_v1, _v2);
-
- /* Check wl_egl_window_v3 ABI against wl_egl_window_v2 */
- CHECK_RENAMED_MEMBER(_v2, _v3, surface, version);
- CHECK_MEMBER (_v2, _v3, width);
- CHECK_MEMBER (_v2, _v3, height);
- CHECK_MEMBER (_v2, _v3, dx);
- CHECK_MEMBER (_v2, _v3, dy);
- CHECK_MEMBER (_v2, _v3, attached_width);
- CHECK_MEMBER (_v2, _v3, attached_height);
- CHECK_RENAMED_MEMBER(_v2, _v3, private, driver_private);
- CHECK_MEMBER (_v2, _v3, resize_callback);
- CHECK_MEMBER (_v2, _v3, destroy_window_callback);
-
- CHECK_SIZE (_v2, _v3);
- CHECK_VERSION(_v2, _v3);
-
- /* Check current wl_egl_window ABI against wl_egl_window_v3 */
- CHECK_MEMBER_CURRENT(_v3, version);
- CHECK_MEMBER_CURRENT(_v3, width);
- CHECK_MEMBER_CURRENT(_v3, height);
- CHECK_MEMBER_CURRENT(_v3, dx);
- CHECK_MEMBER_CURRENT(_v3, dy);
- CHECK_MEMBER_CURRENT(_v3, attached_width);
- CHECK_MEMBER_CURRENT(_v3, attached_height);
- CHECK_MEMBER_CURRENT(_v3, driver_private);
- CHECK_MEMBER_CURRENT(_v3, resize_callback);
- CHECK_MEMBER_CURRENT(_v3, destroy_window_callback);
- CHECK_MEMBER_CURRENT(_v3, surface);
-
- CHECK_SIZE_CURRENT (_v3);
- CHECK_VERSION_CURRENT(_v3);
-
- return 0;
-}
diff --git a/egl/wayland-egl-backend.h b/egl/wayland-egl-backend.h
deleted file mode 100644
index 869c86f..0000000
--- a/egl/wayland-egl-backend.h
+++ /dev/null
@@ -1,67 +0,0 @@
-/*
- * Copyright © 2011 Benjamin Franzke
- *
- * Permission is hereby granted, free of charge, to any person obtaining a
- * copy of this software and associated documentation files (the "Software"),
- * to deal in the Software without restriction, including without limitation
- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
- * and/or sell copies of the Software, and to permit persons to whom the
- * Software is furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice (including the next
- * paragraph) shall be included in all copies or substantial portions of the
- * Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
- * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
- * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
- * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
- * DEALINGS IN THE SOFTWARE.
- *
- * Authors:
- * Benjamin Franzke <benjaminfranzke@googlemail.com>
- */
-
-#ifndef _WAYLAND_EGL_PRIV_H
-#define _WAYLAND_EGL_PRIV_H
-
-#include <stdint.h>
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-/*
- * NOTE: This version must be kept in sync with the Version field in the
- * wayland-egl-backend.pc.in file.
- */
-#define WL_EGL_WINDOW_VERSION 3
-
-struct wl_surface;
-
-struct wl_egl_window {
- const intptr_t version;
-
- int width;
- int height;
- int dx;
- int dy;
-
- int attached_width;
- int attached_height;
-
- void *driver_private;
- void (*resize_callback)(struct wl_egl_window *, void *);
- void (*destroy_window_callback)(void *);
-
- struct wl_surface *surface;
-};
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif
diff --git a/egl/wayland-egl-backend.pc.in b/egl/wayland-egl-backend.pc.in
deleted file mode 100644
index 6cf0ed4..0000000
--- a/egl/wayland-egl-backend.pc.in
+++ /dev/null
@@ -1,9 +0,0 @@
-prefix=@prefix@
-exec_prefix=@exec_prefix@
-includedir=@includedir@
-
-Name: wayland-egl-backend
-Description: Backend wayland-egl interface
-Version: 3
-Libs:
-Cflags: -I${includedir}
diff --git a/egl/wayland-egl-symbols-check b/egl/wayland-egl-symbols-check
deleted file mode 100755
index d04fd04..0000000
--- a/egl/wayland-egl-symbols-check
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/sh
-set -eu
-
-RET=0
-LIB=${WAYLAND_EGL_LIB}
-
-if ! test -f "$LIB"; then
- echo "Test binary \"$LIB\" does not exist"
- exit 99
-fi
-
-if ! test -n "$NM"; then
- echo "nm environment variable not set"
- exit 99
-fi
-
-AVAIL_FUNCS="$($NM -D --format=bsd --defined-only $LIB | awk '{print $3}')"
-
-# Official ABI, taken from the header.
-REQ_FUNCS="wl_egl_window_resize
-wl_egl_window_create
-wl_egl_window_destroy
-wl_egl_window_get_attached_size
-"
-
-NEW_ABI=$(echo "$AVAIL_FUNCS" | while read func; do
- echo "$func" | grep -q "^_" && continue
- echo "$REQ_FUNCS" | grep -q "^$func$" && continue
-
- echo $func
-done)
-
-if test -n "$NEW_ABI"; then
- echo "New ABI detected - If intentional, update the test."
- echo "$NEW_ABI"
- RET=1
-fi
-
-REMOVED_ABI=$(echo "$REQ_FUNCS" | while read func; do
- echo "$AVAIL_FUNCS" | grep -q "^$func$" && continue
-
- echo $func
-done)
-
-if test -n "$REMOVED_ABI"; then
- echo "ABI break detected - Required symbol(s) no longer exported!"
- echo "$REMOVED_ABI"
- RET=1
-fi
-
-exit $RET
diff --git a/egl/wayland-egl.c b/egl/wayland-egl.c
deleted file mode 100644
index a60f899..0000000
--- a/egl/wayland-egl.c
+++ /dev/null
@@ -1,104 +0,0 @@
-/*
- * Copyright © 2011 Kristian Høgsberg
- * Copyright © 2011 Benjamin Franzke
- *
- * Permission is hereby granted, free of charge, to any person obtaining a
- * copy of this software and associated documentation files (the "Software"),
- * to deal in the Software without restriction, including without limitation
- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
- * and/or sell copies of the Software, and to permit persons to whom the
- * Software is furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice (including the next
- * paragraph) shall be included in all copies or substantial portions of the
- * Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
- * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
- * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
- * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
- * DEALINGS IN THE SOFTWARE.
- *
- * Authors:
- * Kristian Høgsberg <krh@bitplanet.net>
- * Benjamin Franzke <benjaminfranzke@googlemail.com>
- */
-
-#include <stdlib.h>
-#include <string.h>
-
-#include "wayland-egl.h"
-#include "wayland-egl-backend.h"
-#include "wayland-util.h"
-
-
-WL_EXPORT void
-wl_egl_window_resize(struct wl_egl_window *egl_window,
- int width, int height,
- int dx, int dy)
-{
- if (width <= 0 || height <= 0)
- return;
-
- egl_window->width = width;
- egl_window->height = height;
- egl_window->dx = dx;
- egl_window->dy = dy;
-
- if (egl_window->resize_callback)
- egl_window->resize_callback(egl_window, egl_window->driver_private);
-}
-
-WL_EXPORT struct wl_egl_window *
-wl_egl_window_create(struct wl_surface *surface,
- int width, int height)
-{
- struct wl_egl_window *egl_window;
-
- if (width <= 0 || height <= 0)
- return NULL;
-
- egl_window = calloc(1, sizeof *egl_window);
- if (!egl_window)
- return NULL;
-
- /* Cast away the constness to set the version number.
- *
- * We want the const notation since it gives an explicit
- * feedback to the backend implementation, should it try to
- * change it.
- *
- * The latter in itself is not too surprising as these days APIs
- * tend to provide bidirectional version field.
- */
- intptr_t *version = (intptr_t *)&egl_window->version;
- *version = WL_EGL_WINDOW_VERSION;
-
- egl_window->surface = surface;
-
- egl_window->width = width;
- egl_window->height = height;
-
- return egl_window;
-}
-
-WL_EXPORT void
-wl_egl_window_destroy(struct wl_egl_window *egl_window)
-{
- if (egl_window->destroy_window_callback)
- egl_window->destroy_window_callback(egl_window->driver_private);
- free(egl_window);
-}
-
-WL_EXPORT void
-wl_egl_window_get_attached_size(struct wl_egl_window *egl_window,
- int *width, int *height)
-{
- if (width)
- *width = egl_window->attached_width;
- if (height)
- *height = egl_window->attached_height;
-}
diff --git a/egl/wayland-egl.pc.in b/egl/wayland-egl.pc.in
deleted file mode 100644
index 2e2d4c4..0000000
--- a/egl/wayland-egl.pc.in
+++ /dev/null
@@ -1,11 +0,0 @@
-prefix=@prefix@
-exec_prefix=@exec_prefix@
-libdir=@libdir@
-includedir=@includedir@
-
-Name: wayland-egl
-Description: Frontend wayland-egl library
-Version: 18.1.0
-Requires: wayland-client
-Libs: -L${libdir} -lwayland-egl
-Cflags: -I${includedir}
--
2.19.1
recipes-graphics/wayland/wayland_%.bbappend
0 → 100644
View file @
ff348b3b
FILESEXTRAPATHS_prepend := "${THISDIR}/wayland:"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment