Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
086fcd36
Commit
086fcd36
authored
Oct 04, 2017
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Adds a telepathy-qt recipe needed by voicecall
parent
6e58d24b
Changes
5
Hide whitespace changes
Inline
Side-by-side
Showing
5 changed files
with
129 additions
and
0 deletions
+129
-0
0001-Don-t-require-QtGui.patch
...ity/telepathy/telepathy-qt/0001-Don-t-require-QtGui.patch
+24
-0
0002-Don-t-require-python.patch
...ty/telepathy/telepathy-qt/0002-Don-t-require-python.patch
+32
-0
0003-Disable-examples-compilation.patch
...athy/telepathy-qt/0003-Disable-examples-compilation.patch
+25
-0
0004-Disable-tests-compilation.patch
...lepathy/telepathy-qt/0004-Disable-tests-compilation.patch
+25
-0
telepathy-qt_git.bb
recipes-connectivity/telepathy/telepathy-qt_git.bb
+23
-0
No files found.
recipes-connectivity/telepathy/telepathy-qt/0001-Don-t-require-QtGui.patch
0 → 100644
View file @
086fcd36
From b6f2c4ecba921f6f685c0c9d1d8838f5a575bd25 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 28 Sep 2017 15:04:02 +0200
Subject: [PATCH] Don't require QtGui
---
cmake/modules/FindQt5.cmake | 1 -
1 file changed, 1 deletion(-)
diff --git a/cmake/modules/FindQt5.cmake b/cmake/modules/FindQt5.cmake
index ffd5dd3..6378f6d 100644
--- a/cmake/modules/FindQt5.cmake
+++ b/cmake/modules/FindQt5.cmake
@@ -66,7 +66,6 @@
find_package(Qt5Core ${REQUIRED_QT_VERSION} REQUIRED)
find_package(Qt5DBus ${REQUIRED_QT_VERSION} REQUIRED)
find_package(Qt5Gui ${REQUIRED_QT_VERSION} REQUIRED)
find_package(Qt5Test ${REQUIRED_QT_VERSION} REQUIRED)
-find_package(Qt5Widgets ${REQUIRED_QT_VERSION} REQUIRED)
find_package(Qt5Network ${REQUIRED_QT_VERSION} REQUIRED)
find_package(Qt5Xml ${REQUIRED_QT_VERSION} REQUIRED)
--
2.7.4
recipes-connectivity/telepathy/telepathy-qt/0002-Don-t-require-python.patch
0 → 100644
View file @
086fcd36
From ea4167c12097786f67136828fb68c29b7e894bba Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 28 Sep 2017 15:06:27 +0200
Subject: [PATCH] Don't require python
---
CMakeLists.txt | 9 ---------
1 file changed, 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a74720..068b555 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,15 +136,6 @@
macro_log_feature(QT_GLIB_SUPPORT "Qt Glib Support"
# reset flags
set(CMAKE_REQUIRED_FLAGS "")
-# Find python version >= 2.7
-set(REQUIRED_PY 2.7)
-find_package(PythonLibrary ${REQUIRED_PY} REQUIRED)
-if(${PYTHON_SHORT_VERSION} VERSION_GREATER ${REQUIRED_PY} OR ${PYTHON_SHORT_VERSION} VERSION_EQUAL ${REQUIRED_PY})
- message(STATUS "Python ${PYTHON_SHORT_VERSION} found")
-else()
- message(SEND_ERROR "Python >= ${REQUIRED_PY} is required")
-endif()
-
# Check for dbus-python
execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import dbus.mainloop.glib"
RESULT_VARIABLE PYTHON_DBUS_RESULT)
--
2.7.4
recipes-connectivity/telepathy/telepathy-qt/0003-Disable-examples-compilation.patch
0 → 100644
View file @
086fcd36
From e1efb911f8fae2fe384ddcb52dc4ffb7744f6e79 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 28 Sep 2017 15:14:26 +0200
Subject: [PATCH] Disable examples compilation
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 068b555..40684c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,7 +90,7 @@
option(ENABLE_SERVICE_SUPPORT "Enable compilation of service side bindings for T
# Add an option to select type of service library
option(FORCE_STATIC_SERVICE_LIBRARY "Force Telepathy-Qt service to be a static library." FALSE)
# Add an option for compiling examples
-option(ENABLE_EXAMPLES "Enable compilation of examples for Telepathy-Qt" TRUE)
+option(ENABLE_EXAMPLES "Enable compilation of examples for Telepathy-Qt" FALSE)
# Add an option for compiling Farstream
option(ENABLE_FARSTREAM "Enable compilation of Farstream bindings" TRUE)
# Add an option for building tests
--
2.7.4
recipes-connectivity/telepathy/telepathy-qt/0004-Disable-tests-compilation.patch
0 → 100644
View file @
086fcd36
From 912e26621187c4aa780dac3ff318d011e65d5dbc Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 28 Sep 2017 17:55:46 +0200
Subject: [PATCH] Disable tests compilation
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a74720..6d842e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,7 +94,7 @@
option(ENABLE_EXAMPLES "Enable compilation of examples for Telepathy-Qt" TRUE)
# Add an option for compiling Farstream
option(ENABLE_FARSTREAM "Enable compilation of Farstream bindings" TRUE)
# Add an option for building tests
-option(ENABLE_TESTS "Enable compilation of automated tests" TRUE)
+option(ENABLE_TESTS "Enable compilation of automated tests" FALSE)
# The doxygen macro requires Qt to have been looked up to enable crosslinking
include(Doxygen)
--
2.7.4
recipes-connectivity/telepathy/telepathy-qt_git.bb
0 → 100644
View file @
086fcd36
SUMMARY = "Telepathy-Qt is a Qt high-level binding for Telepathy"
HOMEPAGE = "https://telepathy.freedesktop.org/doc/telepathy-qt/"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
SRC_URI = "git://anongit.freedesktop.org/git/telepathy/telepathy-qt.git;protocol=https \
file://0001-Don-t-require-QtGui.patch \
file://0002-Don-t-require-python.patch \
file://0003-Disable-examples-compilation.patch \
file://0004-Disable-tests-compilation.patch"
SRCREV = "744b64e59f1eaae86de1eaeda603d779af99b4a0"
PR = "r1"
PV = "+git${SRCPV}"
S = "${WORKDIR}/git"
do_configure_append() {
chmod +x ${S}/tools/*
}
DEPENDS += "qtbase telepathy-farstream"
inherit cmake_qt5
FILES_${PN}-dev += "/usr/lib/cmake"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment