Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
0efc95dd
Commit
0efc95dd
authored
Jul 11, 2015
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Adds missing dependencies and don't install /opt anymore
parent
abe494bb
Changes
16
Hide whitespace changes
Inline
Side-by-side
Showing
16 changed files
with
78 additions
and
20 deletions
+78
-20
cor_git.bb
recipes-qt/qt5/cor_git.bb
+4
-0
dsme.service
recipes-qt/qt5/dsme/dsme.service
+24
-0
dsme_git.bb
recipes-qt/qt5/dsme_git.bb
+13
-2
libdsme_git.bb
recipes-qt/qt5/libdsme_git.bb
+2
-1
libiphb_git.bb
recipes-qt/qt5/libiphb_git.bb
+6
-3
libngf-qt_git.bb
recipes-qt/qt5/libngf-qt_git.bb
+2
-1
libngf_git.bb
recipes-qt/qt5/libngf_git.bb
+2
-2
libresource_git.bb
recipes-qt/qt5/libresource_git.bb
+1
-1
lipstick_git.bb
recipes-qt/qt5/lipstick_git.bb
+3
-3
mlite_git.bb
recipes-qt/qt5/mlite_git.bb
+6
-1
qt5-qpa-hwcomposer-plugin_git.bb
recipes-qt/qt5/qt5-qpa-hwcomposer-plugin_git.bb
+2
-1
qtaround_git.bb
recipes-qt/qt5/qtaround_git.bb
+6
-1
qtbase_git.bbappend
recipes-qt/qt5/qtbase_git.bbappend
+1
-1
statefs-qt_git.bb
recipes-qt/qt5/statefs-qt_git.bb
+1
-1
usb-moded-qt5_git.bb
recipes-qt/qt5/usb-moded-qt5_git.bb
+4
-0
usb-moded_git.bb
recipes-qt/qt5/usb-moded_git.bb
+1
-2
No files found.
recipes-qt/qt5/cor_git.bb
View file @
0efc95dd
...
...
@@ -13,3 +13,7 @@ inherit cmake
DEPENDS+=" tut udev "
EXTRA_OECMAKE=" -DVERSION=0.1.17"
do_install_append() {
rm -rf ${D}/opt
}
recipes-qt/qt5/dsme/dsme.service
0 → 100644
View file @
0efc95dd
[Unit]
Description=DSME
DefaultDependencies=no
Requires=dbus.service
After=local-fs.target dbus.service
Conflicts=shutdown.target
[Service]
Type=notify
# When starting dsme gets initial runlevel from the bootstate file
# If it doesn't exist, we default to USER
# This works because EnvironmentFile overrides Environment
Environment=BOOTSTATE=USER
EnvironmentFile=-/run/systemd/boot-status/bootstate
EnvironmentFile=-/var/lib/environment/dsme/*.conf
ExecStart=/usr/sbin/dsme -p /usr/lib/dsme/libstartup.so --systemd
Restart=always
RestartSec=1
StartLimitInterval=600
StartLimitBurst=3
StartLimitAction=reboot
[Install]
WantedBy=multi-user.target
recipes-qt/qt5/dsme_git.bb
View file @
0efc95dd
...
...
@@ -3,13 +3,14 @@ HOMEPAGE = "https://github.com/nemomobile/dsme"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
SRC_URI = "git://github.com/nemomobile/dsme;protocol=https"
SRC_URI = "git://github.com/nemomobile/dsme;protocol=https \
file://dsme.service"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "
qtbase libdsme glib-2.0 libngf libiphb systemd
"
DEPENDS += "
qtbase libdsme glib-2.0 libngf libiphb systemd dbus dbus-glib
"
inherit autotools pkgconfig
B = "${WORKDIR}/git"
...
...
@@ -25,3 +26,13 @@ do_compile() {
find . -type f -print0 | xargs -0 sed -i "s/\-Werror//"
oe_runmake V=1
}
do_install_append() {
install -D -m 644 reboot-via-dsme.sh ${D}/etc/profile.d/reboot-via-dsme.sh
install -D -m 644 ../dsme.service ${D}/lib/systemd/system/dsme.service
install -d ${D}/lib/systemd/system/multi-user.target.wants/
ln -s ../dsme.service ${D}/lib/systemd/system/multi-user.target.wants/dsme.service
install -d ${D}/var/lib/dsme
[ ! -f ${D}/var/lib/dsme/alarm_queue_status ] && echo 0 > ${D}/var/lib/dsme/alarm_queue_status
rm -rf ${D}/opt
}
recipes-qt/qt5/libdsme_git.bb
View file @
0efc95dd
...
...
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/nemomobile/libdsme.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS += " glib-2.0"
DEPENDS += " glib-2.0
"
SRC_URI = "git://github.com/nemomobile/libdsme.git;protocol=https \
file://001-Allows-custom-cflags.patch \
...
...
@@ -15,4 +15,5 @@ S = "${WORKDIR}/git"
do_install() {
oe_runmake install DESTDIR=${D}
rm -rf ${D}/opt
}
recipes-qt/qt5/libiphb_git.bb
View file @
0efc95dd
...
...
@@ -5,14 +5,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/nemomobile/libiphb.git;protocol=https"
DEPENDS += "glib-2.0 libdsme"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "
mcedevel
"
DEPENDS += "
mcedevel glib-2.0 dbus-glib dbus libdsme
"
inherit autotools pkgconfig
B = "${WORKDIR}/git"
do_install_append() {
rm -rf ${D}/opt
}
recipes-qt/qt5/libngf-qt_git.bb
View file @
0efc95dd
...
...
@@ -9,11 +9,12 @@ PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " qtbase
libngf qtdeclarative
"
DEPENDS += " qtbase
qtquick1 libngf dbus
"
inherit qmake5
do_install_append() {
mv ${D}/lib/* ${D}/usr/lib/
mv ${D}/include/* ${D}/usr/include/
rmdir ${D}/include/
rm -rf ${D}/opt/
}
recipes-qt/qt5/libngf_git.bb
View file @
0efc95dd
...
...
@@ -3,12 +3,12 @@ HOMEPAGE = "https://github.com/nemomobile/libngf.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
DEPENDS += " dbus "
SRC_URI = "git://github.com/nemomobile/libngf.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " glib-2.0 dbus dbus-glib "
inherit autotools pkgconfig
recipes-qt/qt5/libresource_git.bb
View file @
0efc95dd
...
...
@@ -9,5 +9,5 @@ PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "
dbus-glib
"
DEPENDS += "
glib-2.0 dbus-glib dbus
"
inherit autotools pkgconfig
recipes-qt/qt5/lipstick_git.bb
View file @
0efc95dd
SUMMARY = "Lipstick is a project aimed at offering easy to modify user experiences for varying mobile device form factors, e.g. handsets, netbooks, tablets."
HOMEPAGE = "https://github.com/nemomobile/lipstick"
LICENSE = "LGPL"
LICENSE = "LGPL
-2.1+
"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = "git://github.com/nemomobile/lipstick.git;protocol=https"
SRC_URI[md5sum] = "d1b7dc2ee09b51192b14083292135c69"
SRC_URI[sha256sum] = "aa8049c9d49bb035f526d19a2bfb7d8e5b78c810946b10dcbd1d02c7a88520e4"
SRCREV = "
${AUTOREV}
"
SRCREV = "
c46f99a9edbd9fae19a810d9773fb4f164d88b7c
"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " qtbase qtsensors qtquick1 qtwayland mlite dbus dbus-glib libresourceqt
libngf-qt systemd statefs-qt mce usb-moded-qt5
"
DEPENDS += " qtbase qtsensors qtquick1 qtwayland mlite dbus dbus-glib libresourceqt
qtsystems libngf-qt statefs-qt mce usb-moded-qt5 systemd wayland
"
inherit qmake5
...
...
recipes-qt/qt5/mlite_git.bb
View file @
0efc95dd
...
...
@@ -9,7 +9,12 @@ PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "
qtbase qtbase-native
"
DEPENDS += "
qtbase glib-2.0
"
inherit qmake5
B = "${WORKDIR}/git"
# Out of dir build breaks mlite5.pc installation
do_install_append() {
rm -rf ${D}/opt
}
recipes-qt/qt5/qt5-qpa-hwcomposer-plugin_git.bb
View file @
0efc95dd
...
...
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://hwcomposer_backend.cpp;beginline=1;endline=40;md5=09c
PV = "5.2.0+gitr${SRCPV}"
DEPENDS = "
qtbase libhybris mtdev glib-2.0 udev qtwayland virtual/android-headers
"
DEPENDS = "
qtbase libhybris mtdev glib-2.0 udev qtwayland virtual/android-headers
"
# We need to be ${MACHINE_ARCH} as we need to compile the source against a specific
# Android version we select per machine
...
...
@@ -19,6 +19,7 @@ SRCREV = "${AUTOREV}"
SRC_URI_append_tenderloin = " \
file://0001-Unblock-rendering-for-Android-4.4.4-and-hwcomposer-1.patch;striplevel=2 \
file://0002-Add-QCOM_BSP-define-switch.patch;striplevel=2 \
file://003-Disable_hwcomposer_backend_v0.patch;striplevel=2 \
"
inherit qmake5
...
...
recipes-qt/qt5/qtaround_git.bb
View file @
0efc95dd
...
...
@@ -9,7 +9,12 @@ PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "
qtbase tut
"
DEPENDS += "
qtbase tut cor
"
inherit cmake_qt5
EXTRA_OECMAKE=" -DVERSION=0.2.6 -DOE_QMAKE_PATH_EXTERNAL_HOST_BINS=${STAGING_DIR_NATIVE}/usr/bin/qt5/"
do_install_append() {
rm -rf ${D}/opt
}
recipes-qt/qt5/qtbase_git.bbappend
View file @
0efc95dd
# Remove dependencies to mesa
PACKAGECONFIG_remove = "kms"
PACKAGECONFIG_remove = "gl"
PACKAGECONFIG_
remove
= "gles2"
PACKAGECONFIG_
append
= "gles2"
PACKAGECONFIG_append = "mtdev"
PACKAGECONFIG_append = "linuxfb"
recipes-qt/qt5/statefs-qt_git.bb
View file @
0efc95dd
...
...
@@ -11,7 +11,7 @@ PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
INSANE_SKIP_statefs-qt += "dev-deps"
DEPENDS += " qtbase
cor qtaround qtdeclarative
"
DEPENDS += " qtbase
qtquick1 cor qtaround
"
inherit cmake_qt5
B = "${WORKDIR}/git"
...
...
recipes-qt/qt5/usb-moded-qt5_git.bb
View file @
0efc95dd
...
...
@@ -11,3 +11,7 @@ S = "${WORKDIR}/git"
DEPENDS += "qtbase usb-moded"
inherit qmake5
do_install_append() {
mv ${D}/include ${D}/usr/
}
recipes-qt/qt5/usb-moded_git.bb
View file @
0efc95dd
...
...
@@ -3,8 +3,6 @@ HOMEPAGE = "https://github.com/nemomobile/usb-moded"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5f30f0716dfdd0d91eb439ebec522ec2"
DEPENDS += "glib-2.0 udev dbus-glib dbus"
SRC_URI = "git://github.com/nemomobile/usb-moded;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
...
...
@@ -15,6 +13,7 @@ inherit autotools pkgconfig
B = "${WORKDIR}/git"
EXTRA_OECONF="--enable-systemd "
DEPENDS += " dbus dbus-glib glib-2.0 udev kmod systemd "
do_configure_prepend() {
sed -i "s@systemd-daemon@systemd@" configure.ac
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment