Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
0ffbbed5
Commit
0ffbbed5
authored
Oct 11, 2017
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Upgrade qt5-qpa-hwcomposer-plugin for a version that, notably, work on mtk devices
parent
1e3dd4b5
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
166 additions
and
2 deletions
+166
-2
0003-Fix-build-with-Qt-5.9.patch
...t5-qpa-hwcomposer-plugin/0003-Fix-build-with-Qt-5.9.patch
+163
-0
qt5-qpa-hwcomposer-plugin_git.bb
recipes-qt/qt5/qt5-qpa-hwcomposer-plugin_git.bb
+3
-2
No files found.
recipes-qt/qt5/qt5-qpa-hwcomposer-plugin/0003-Fix-build-with-Qt-5.9.patch
0 → 100644
View file @
0ffbbed5
From 70a9816b0ae99e1e1906e56c34c1f10e983dac82 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Wed, 11 Oct 2017 21:42:05 +0200
Subject: [PATCH] Fix build with Qt 5.9
---
hwcomposer/hwcomposer.pro | 2 +-
hwcomposer/hwcomposer_backend_v11.cpp | 14 --------------
hwcomposer/hwcomposer_context.h | 2 +-
hwcomposer/qeglfscontext.cpp | 2 +-
hwcomposer/qeglfscontext.h | 4 ++--
hwcomposer/qeglfsintegration.cpp | 12 ++++++------
hwcomposer/qeglfswindow.cpp | 2 +-
7 files changed, 12 insertions(+), 26 deletions(-)
diff --git a/hwcomposer/hwcomposer.pro b/hwcomposer/hwcomposer.pro
index c394286..4adcf03 100644
--- a/hwcomposer/hwcomposer.pro
+++ b/hwcomposer/hwcomposer.pro
@@ -28,7 +28,7 @@
SOURCES += hwcomposer_backend_v11.cpp
HEADERS += hwcomposer_backend_v11.h
-QT += core-private compositor-private gui-private platformsupport-private dbus
+QT += core-private waylandcompositor-private gui-private egl_support-private fontdatabase_support-private theme_support-private eventdispatcher_support-private dbus
DEFINES += QEGL_EXTRA_DEBUG
CONFIG += egl qpa/genericunixfontdatabase
diff --git a/hwcomposer/hwcomposer_backend_v11.cpp b/hwcomposer/hwcomposer_backend_v11.cpp
index 318e456..26ee1cc 100644
--- a/hwcomposer/hwcomposer_backend_v11.cpp
+++ b/hwcomposer/hwcomposer_backend_v11.cpp
@@ -48,8 +48,6 @@
#include <QtCore/QCoreApplication>
#include <private/qwindow_p.h>
-#include <private/qsystrace_p.h>
-
#ifdef HWC_PLUGIN_HAVE_HWCOMPOSER1_API
// #define QPA_HWC_TIMING
@@ -73,13 +71,6 @@
struct HwcProcs_v11 : public hwc_procs
static void hwc11_callback_vsync(const struct hwc_procs *procs, int, int64_t)
{
- static int counter = 0;
- ++counter;
- if (counter % 2)
- QSystrace::begin("graphics", "QPA::vsync", "");
- else
- QSystrace::end("graphics", "QPA::vsync", "");
-
QCoreApplication::postEvent(static_cast<const HwcProcs_v11 *>(procs)->backend, new QEvent(QEvent::User));
}
@@ -125,8 +116,6 @@
HWComposer::HWComposer(unsigned int width, unsigned int height, unsigned int for
void HWComposer::present(HWComposerNativeWindowBuffer *buffer)
{
- QSystraceEvent trace("graphics", "QPA::present");
-
QPA_HWC_TIMING_SAMPLE(presentTime);
fblayer->handle = buffer->handle;
@@ -150,10 +139,8 @@
void HWComposer::present(HWComposerNativeWindowBuffer *buffer)
QPA_HWC_TIMING_SAMPLE(prepareTime);
- QSystrace::begin("graphics", "QPA::set", "");
err = hwcdevice->set(hwcdevice, num_displays, mlist);
HWC_PLUGIN_EXPECT_ZERO(err);
- QSystrace::end("graphics", "QPA::set", "");
QPA_HWC_TIMING_SAMPLE(setTime);
@@ -420,7 +407,6 @@
bool HwComposerBackend_v11::event(QEvent *e)
void HwComposerBackend_v11::handleVSyncEvent()
{
- QSystraceEvent trace("graphics", "QPA::handleVsync");
QSet<QWindow *> pendingWindows = m_pendingUpdate;
m_pendingUpdate.clear();
foreach (QWindow *w, pendingWindows) {
diff --git a/hwcomposer/hwcomposer_context.h b/hwcomposer/hwcomposer_context.h
index 5687c47..1d78a2c 100644
--- a/hwcomposer/hwcomposer_context.h
+++ b/hwcomposer/hwcomposer_context.h
@@ -52,7 +52,7 @@
#include <QtGui/QSurfaceFormat>
#include <QtGui/QImage>
#include <EGL/egl.h>
-#include <QtPlatformSupport/private/qeglplatformcontext_p.h>
+#include <QtEglSupport/private/qeglplatformcontext_p.h>
QT_BEGIN_NAMESPACE
diff --git a/hwcomposer/qeglfscontext.cpp b/hwcomposer/qeglfscontext.cpp
index e9d8201..aafff48 100644
--- a/hwcomposer/qeglfscontext.cpp
+++ b/hwcomposer/qeglfscontext.cpp
@@ -42,7 +42,7 @@
#include "qeglfscontext.h"
#include "qeglfswindow.h"
#include "qeglfsintegration.h"
-#include <QtPlatformSupport/private/qeglpbuffer_p.h>
+#include <QtEglSupport/private/qeglpbuffer_p.h>
#include <QtGui/QSurface>
#include <QtDebug>
diff --git a/hwcomposer/qeglfscontext.h b/hwcomposer/qeglfscontext.h
index c5da9fc..c6544ea 100644
--- a/hwcomposer/qeglfscontext.h
+++ b/hwcomposer/qeglfscontext.h
@@ -42,8 +42,8 @@
#ifndef QEGLFSCONTEXT_H
#define QEGLFSCONTEXT_H
-#include <QtPlatformSupport/private/qeglconvenience_p.h>
-#include <QtPlatformSupport/private/qeglplatformcontext_p.h>
+#include <QtEglSupport/private/qeglconvenience_p.h>
+#include <QtEglSupport/private/qeglplatformcontext_p.h>
#include "hwcomposer_context.h"
diff --git a/hwcomposer/qeglfsintegration.cpp b/hwcomposer/qeglfsintegration.cpp
index b92137b..112bfd8 100644
--- a/hwcomposer/qeglfsintegration.cpp
+++ b/hwcomposer/qeglfsintegration.cpp
@@ -46,12 +46,12 @@
#include <QtGui/private/qguiapplication_p.h>
-#include <QtPlatformSupport/private/qgenericunixfontdatabase_p.h>
-#include <QtPlatformSupport/private/qgenericunixeventdispatcher_p.h>
-#include <QtPlatformSupport/private/qgenericunixthemes_p.h>
-#include <QtPlatformSupport/private/qeglconvenience_p.h>
-#include <QtPlatformSupport/private/qeglplatformcontext_p.h>
-#include <QtPlatformSupport/private/qeglpbuffer_p.h>
+#include <QtFontDatabaseSupport/private/qgenericunixfontdatabase_p.h>
+#include <QtEventDispatcherSupport/private/qgenericunixeventdispatcher_p.h>
+#include <QtThemeSupport/private/qgenericunixthemes_p.h>
+#include <QtEglSupport/private/qeglconvenience_p.h>
+#include <QtEglSupport/private/qeglplatformcontext_p.h>
+#include <QtEglSupport/private/qeglpbuffer_p.h>
#include <qpa/qplatformwindow.h>
#include <qpa/qplatformservices.h>
diff --git a/hwcomposer/qeglfswindow.cpp b/hwcomposer/qeglfswindow.cpp
index c8bd9ce..97301b4 100644
--- a/hwcomposer/qeglfswindow.cpp
+++ b/hwcomposer/qeglfswindow.cpp
@@ -42,7 +42,7 @@
#include "qeglfswindow.h"
#include <qpa/qwindowsysteminterface.h>
-#include <QtPlatformSupport/private/qeglconvenience_p.h>
+#include <QtEglSupport/private/qeglconvenience_p.h>
#include <QtDebug>
--
2.7.4
recipes-qt/qt5/qt5-qpa-hwcomposer-plugin_git.bb
View file @
0ffbbed5
...
...
@@ -12,9 +12,10 @@ DEPENDS = "qtbase qtsensors libhybris mtdev glib-2.0 udev qtwayland virtual/andr
# Android version we select per machine
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI = "git://github.com/AsteroidOS/qt5-qpa-hwcomposer-plugin;protocol=https"
SRC_URI = "git://github.com/mer-hybris/qt5-qpa-hwcomposer-plugin;protocol=https \
file://0003-Fix-build-with-Qt-5.9.patch;striplevel=2"
S = "${WORKDIR}/git/hwcomposer"
SRCREV = "
2356f482b64dbe5ee62115ab93778dec625e2206
"
SRCREV = "
bb95d09b893761c25409363e15f7048739c436ba
"
inherit qmake5
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment