Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
20c75bec
Commit
20c75bec
authored
Apr 11, 2017
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Downgrade Mesa in order to ave libegl-gallium which is needed for graphics rendering on QEMU
parent
c2dc83f9
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
106 additions
and
0 deletions
+106
-0
0001-Revert-egl-Check-for-NULL-native_window-in-eglCreate.patch
...evert-egl-Check-for-NULL-native_window-in-eglCreate.patch
+29
-0
0001-loader-include-sys-stat.h-for-non-sysfs-builds.patch
...0001-loader-include-sys-stat.h-for-non-sysfs-builds.patch
+40
-0
mesa_10.3.7.bb
recipes-graphics/mesa/mesa_10.3.7.bb
+37
-0
No files found.
recipes-graphics/mesa/mesa/0001-Revert-egl-Check-for-NULL-native_window-in-eglCreate.patch
0 → 100644
View file @
20c75bec
From b22b038d0526050e972e1f52261033fedd45403f Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Tue, 22 Sep 2015 20:57:54 +0200
Subject: [PATCH] Revert "egl: Check for NULL native_window in
eglCreateWindowSurface"
This reverts commit 91ff0d4c6510dc38f279c586ced17fba917873e7.
---
src/egl/main/eglapi.c | 4 ----
1 file changed, 4 deletions(-)
diff --git a/src/egl/main/eglapi.c b/src/egl/main/eglapi.c
index 096c3d8..7846814 100644
--- a/src/egl/main/eglapi.c
+++ b/src/egl/main/eglapi.c
@@ -571,10 +571,6 @@
_eglCreateWindowSurfaceCommon(_EGLDisplay *disp, EGLConfig config,
EGLSurface ret;
_EGL_CHECK_CONFIG(disp, conf, EGL_NO_SURFACE, drv);
-
- if (native_window == NULL)
- RETURN_EGL_ERROR(disp, EGL_BAD_NATIVE_WINDOW, EGL_NO_SURFACE);
-
surf = drv->API.CreateWindowSurface(drv, disp, conf, native_window,
attrib_list);
ret = (surf) ? _eglLinkSurface(surf) : EGL_NO_SURFACE;
--
2.5.1
recipes-graphics/mesa/mesa/0001-loader-include-sys-stat.h-for-non-sysfs-builds.patch
0 → 100644
View file @
20c75bec
From d1f3d522b78036feb89d1f7c23dea66aed52673f Mon Sep 17 00:00:00 2001
From: Emil Velikov <emil.l.velikov@gmail.com>
Date: Wed, 11 Mar 2015 19:12:35 +0000
Subject: [PATCH] loader: include <sys/stat.h> for non-sysfs builds
Required by fstat(), otherwise we'll error out due to implicit function
declaration.
Cc: "10.4 10.5" <mesa-stable@lists.freedesktop.org>
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89530
Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Reported-by: Vadim Rutkovsky <vrutkovs@redhat.com>
Tested-by: Vadim Rutkovsky <vrutkovs@redhat.com>
---
src/loader/loader.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/loader/loader.c b/src/loader/loader.c
index 47e1f58..72414c5 100644
--- a/src/loader/loader.c
+++ b/src/loader/loader.c
@@ -64,6 +64,7 @@
* Rob Clark <robclark@freedesktop.org>
*/
+#include <sys/stat.h>
#include <stdarg.h>
#include <stdio.h>
#include <string.h>
@@ -80,7 +81,6 @@
#endif
#endif
#ifdef HAVE_SYSFS
-#include <sys/stat.h>
#include <sys/types.h>
#endif
#include "loader.h"
--
2.6.0
recipes-graphics/mesa/mesa_10.3.7.bb
0 → 100644
View file @
20c75bec
require recipes-graphics/mesa/${BPN}.inc
# different license.html than 12.* version used in oe-core
LIC_FILES_CHKSUM = "file://docs/license.html;md5=6a23445982a7a972ac198e93cc1cb3de"
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/older-versions/10.x/${PV}/MesaLib-${PV}.tar.bz2 \
file://0001-Revert-egl-Check-for-NULL-native_window-in-eglCreate.patch \
file://0001-loader-include-sys-stat.h-for-non-sysfs-builds.patch \
"
SRC_URI[md5sum] = "8c540465ed7700a24dab7746d400326b"
SRC_URI[sha256sum] = "43c6ced15e237cbb21b3082d7c0b42777c50c1f731d0d4b5efb5231063fb6a5b"
S = "${WORKDIR}/Mesa-${PV}"
# This version doesn't have --with-sha option
PACKAGECONFIG_remove = "${MESA_CRYPTO}"
PACKAGECONFIG[gallium-egl] = "--enable-gallium-egl, --disable-gallium-egl"
PACKAGECONFIG[gallium-gbm] = "--enable-gallium-gbm, --disable-gallium-gbm"
PACKAGES =+ "libegl-gallium libgbm-gallium"
FILES_libegl-gallium = "${libdir}/egl/egl_gallium.so*"
FILES_libgbm-gallium = "${libdir}/gbm/gbm_gallium_drm.so*"
# We want the fbdev platform as well
EGL_PLATFORMS_append = ",fbdev"
PACKAGECONFIG_append = " gallium-egl gallium-gbm gallium"
#because we cannot rely on the fact that all apps will use pkgconfig,
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment