Commit 48bbfa6f authored by Florent Revest's avatar Florent Revest

Add missing content in previous few commits

parent b1c3962c
From 930cf7fce3ddd3279ca24a953c1929525668ed02 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Thu, 31 Aug 2017 16:22:15 +0100
Subject: [PATCH] Install modules to /usr/lib/pulse-10.0/
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 3530660..9430563 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,8 +20,8 @@ AC_PROG_CC_C99
AM_PROG_CC_C_O
AC_PROG_GCC_TRADITIONAL
-m4_define(pa_major, `echo $VERSION | cut -d. -f1 | cut -d- -f1`)
-m4_define(pa_minor, `echo $VERSION | cut -d. -f2 | cut -d- -f1`)
+m4_define(pa_major, `echo 10`)
+m4_define(pa_minor, `echo 0`)
AC_SUBST(PA_MAJOR, pa_major)
AC_SUBST(PA_MAJORMINOR, pa_major.pa_minor)
--
2.7.4
From d87264156feedf8b194967c6758d1eea43e33c33 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Fri, 8 Sep 2017 14:52:31 +0200
Subject: [PATCH] configure.ac: Check hardfp from cross compilation toolchain
instead of host
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 8b28613..15b07f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,7 +221,7 @@ if test "x$x86" = xyes ; then
fi
AC_MSG_CHECKING([If we are using hardfp tool chain])
-case `echo | gcc -v -xc -o - - 2>&1 | grep COLLECT_GCC_OPTIONS | tail -1` in
+case `echo | $CC -v -xc -o - - 2>&1 | grep COLLECT_GCC_OPTIONS | tail -1` in
*float-abi=hard*) hardfp=yes; AC_MSG_RESULT([yes]) ;;
*) hardfp=no; AC_MSG_RESULT([no]) ;;
esac
--
2.7.4
From b5d5f6b3d91f9d448e7f0aaddf9686615c7f7a66 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Fri, 8 Sep 2017 15:09:10 +0200
Subject: [PATCH] Install modules to /usr/lib/pulse-10.0/
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 8b28613..4b7f016 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,8 +20,8 @@ AC_PROG_CC_C99
AM_PROG_CC_C_O
AC_PROG_GCC_TRADITIONAL
-m4_define(pa_major, `echo $VERSION | cut -d. -f1 | cut -d- -f1`)
-m4_define(pa_minor, `echo $VERSION | cut -d. -f2 | cut -d- -f1`)
+m4_define(pa_major, `echo 10`)
+m4_define(pa_minor, `echo 0`)
AC_SUBST(PA_MAJOR, pa_major)
AC_SUBST(PA_MAJORMINOR, pa_major.pa_minor)
--
2.7.4
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out. Use either ; or # for
## commenting.
; default-sink =
; default-source =
; default-server =
; default-dbus-server =
; autospawn = yes
; allow-autospawn-for-root = no
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog
; cookie-file =
; enable-shm = no
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; auto-connect-localhost = no
; auto-connect-display = no
......@@ -16,17 +16,24 @@
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix
load-module module-droid-keepalive
load-module module-dbus-protocol
load-module module-meego-parameters cache=0 directory=/var/lib/nemo-pulseaudio-parameters use_voice=false
load-module module-meego-mainvolume virtual_stream=true
load-module module-stream-restore-nemo restore_device=no restore_volume=yes restore_muted=no route_table=/etc/pulse/x-maemo-route.table fallback_table=/etc/pulse/x-maemo-stream-restore.table use_voice=false
load-module module-match table=/etc/pulse/x-maemo-match.table key=application.name
.ifexists module-droid-card.so
load-module module-droid-card source_channel_map=mono
.endif
### Automatically restore the volume of streams and devices
load-module module-stream-restore
load-module module-device-restore
### Automatically restore the default sink/source when changed by the user
......
timeout = 1200
role-list = x-maemo
mode-list = lineout,hs
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-5850,2:-5525,3:-5200,4:-4875,5:-4550,6:-4225,7:-3900,8:-3575,9:-3250,10:-2925,11:-2600,12:-2275,13:-1950,14:-1625,15:-1300,16:-975,17:-650,18:-325,19:0"
x-nemo.mainvolume.high-volume-step = "15"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-6175,1:-5850,2:-5525,3:-5200,4:-4875,5:-4550,6:-4225,7:-3900,8:-3575,9:-3250,10:-2925,11:-2600,12:-2275,13:-1950,14:-1625,15:-1300,16:-975,17:-650,18:-325,19:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-3800,2:-3187,3:-2648,4:-2158,5:-1716,6:-1324,7:-932,8:-612,9:-368,10:-122,11:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-5500,2:-5000,3:-4500,4:-4000,5:-3600,6:-3200,7:-2800,8:-2500,9:-2200,10:-1900,11:-1600,12:-1300,13:-1100,14:-950,15:-800,16:-600,17:-400,18:-200,19:0"
x-nemo.mainvolume.high-volume-step = "12"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-5850,2:-5525,3:-5200,4:-4875,5:-4550,6:-4225,7:-3900,8:-3575,9:-3250,10:-2925,11:-2600,12:-2275,13:-1950,14:-1625,15:-1300,16:-975,17:-650,18:-325,19:0"
x-nemo.mainvolume.high-volume-step = "15"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-6175,1:-5850,2:-5525,3:-5200,4:-4875,5:-4550,6:-4225,7:-3900,8:-3575,9:-3250,10:-2925,11:-2600,12:-2275,13:-1950,14:-1625,15:-1300,16:-975,17:-650,18:-325,19:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-5500,2:-5000,3:-4500,4:-4000,5:-3600,6:-3200,7:-2800,8:-2500,9:-2200,10:-1900,11:-1600,12:-1300,13:-1100,14:-950,15:-800,16:-600,17:-400,18:-200,19:0"
x-nemo.mainvolume.high-volume-step = "12"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-3800,2:-3187,3:-2648,4:-2158,5:-1716,6:-1324,7:-932,8:-612,9:-368,10:-122,11:0"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-20000,1:-6175,2:-4875,3:-3625,4:-3025,5:-2425,6:-2025,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-250,14:-125,15:0"
x-nemo.mainvolume.media = "0:-20000,1:-6175,2:-4875,3:-4225,4:-3625,5:-3025,6:-2425,7:-1815,8:-1625,9:-1200,10:-1025,11:-700,12:-575,13:-450,14:-225,15:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-3800,2:-3187,3:-2648,4:-2158,5:-1716,6:-1324,7:-932,8:-612,9:-368,10:-122,11:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-3800,2:-3187,3:-2648,4:-2158,5:-1716,6:-1324,7:-932,8:-612,9:-368,10:-122,11:0"
x-nemo.mainvolume.call = "0:-6000,1:-1400,2:-800,3:-450,4:-190,5:0"
x-nemo.mainvolume.media = "0:-20000,1:-5500,2:-5000,3:-4500,4:-4000,5:-3600,6:-3200,7:-2800,8:-2500,9:-2200,10:-1900,11:-1600,12:-1300,13:-1100,14:-950,15:-800,16:-600,17:-400,18:-200,19:0"
x-nemo.mainvolume.high-volume-step = "12"
sink-input-by-media-role:x-maemo -20
sink-input-by-media-role:phone -15
telepathy-stream-engine "phone"
tonegend "dtmf-tone"
voicehost "phone"
. "x-maemo"
sink-input-by-media-role:x-maemo -20
sink-input-by-media-role:phone -15
sink-input-by-media-role:animation -20
sink-input-by-media-role:x-maemo -25
sink-input-by-media-role:phone -15
sink-input-by-media-role:x-maemo -20
sink-input-by-media-role:phone -15
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment