Commit 690b63a5 authored by Florent Revest's avatar Florent Revest

Initial commit

parents
This diff is collapsed.
# Copyright (C) 2015 Florent Revest <revestflo@gmail.com>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2 as
# published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License along
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
MAINTAINER = "Florent Revest <revestflo@gmail.com>"
# Distro setup
DISTRO = "asteroid"
DISTRO_NAME = "Asteroid"
DISTRO_VERSION ?= "${DATE}-snapshot"
DISTRO_FEATURES = "wayland systemd alsa ipv4 ${DISTRO_FEATURES_LIBC}"
PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"
VIRTUAL-RUNTIME_init_manager = "systemd"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
VIRTUAL-RUNTIME_initscripts = ""
PREFERRED_PROVIDER_udev = "systemd"
# We have a conf and classes directory, append to BBPATH
BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "boot2efl-layer"
BBFILE_PATTERN_boot2efl-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_boot2efl-layer = "7"
inherit core-image
DESCRIPTION = "Asteroid Image."
LICENSE = "GPL-2.0"
IMAGE_INSTALL += "base-files base-passwd netbase keymaps strace ltrace procps gdb dosfstools nano bash acl coreutils e2fsprogs file findutils gawk grep makedevs mktemp ncurses net-tools psmisc sed tar time util-linux zlib iproute2 iputils iptables module-init-tools openssl ethtool gzip shadow sudo at bzip2 elfutils dbus dbus-glib less logrotate tzdata sysfsutils systemd qtbase qtbase-tools qt5-qpa-hwcomposer-plugin lipstick qt5everywheredemo"
IMAGE_FEATURES += "splash package-management"
SUMMARY = "Nemomobile's Cor"
HOMEPAGE = "https://github.com/nemomobile/cor"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d2c621b4dd653efb7cbad641e0a30c59"
SRC_URI = "git://github.com/nemomobile/cor;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit cmake
DEPENDS+=" tut "
EXTRA_OECMAKE=" -DVERSION=0.1.17"
SUMMARY = "Nemomobile's DSME"
HOMEPAGE = "https://github.com/nemomobile/dsme"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
SRC_URI = "git://github.com/nemomobile/dsme;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "qtbase libdsme glib-2.0 libngf libiphb systemd"
inherit autotools pkgconfig
B = "${WORKDIR}/git"
# Poweron-timer needs libcal but I can't find it
EXTRA_OECONF= " --disable-poweron-timer --disable-upstart --enable-systemd --enable-runlevel --enable-pwrkeymonitor --disable-static"
do_configure_prepend() {
sed -i "s/\lsystemd-daemon/lsystemd/" dsme/Makefile.am
sed -i "s@LDFLAGS \= \-pthread@LDFLAGS \= \-L${STAGING_DIR_TARGET}/usr/lib \-pthread@" modules/Makefile.am
}
do_compile() {
find . -type f -print0 | xargs -0 sed -i "s/\-Werror//"
oe_runmake V=1
}
commit d474b630a62265e2090489a9048f510d3d8d2746
Author: Florent Revest <revestflo@gmail.com>
Date: Fri Jun 5 13:28:45 2015 +0200
Allows use of custom CFLAGS
diff --git a/Makefile b/Makefile
index 18067ca..d1fa663 100644
--- a/Makefile
+++ b/Makefile
@@ -100,13 +100,13 @@ install_tests::
# Common options
# ----------------------------------------------------------------------------
-CFLAGS += -O2
-CFLAGS += -Wall -Wwrite-strings -Wmissing-prototypes -Werror
+override CFLAGS += -O2
+override CFLAGS += -Wall -Wwrite-strings -Wmissing-prototypes -Werror
-CFLAGS += -g
-LDFLAGS += -g
+override CFLAGS += -g
+override LDFLAGS += -g
-LDFLAGS += -Wl,--as-needed
+override LDFLAGS += -Wl,--as-needed
# ----------------------------------------------------------------------------
# libdsme$(SOVERS) and libdsme.a
@@ -115,11 +115,11 @@ LDFLAGS += -Wl,--as-needed
libdsme_OBJ += protocol.pic.o message.pic.o alarm_limit.pic.o
libdsme_PC += glib-2.0
-libdsme$(SOVERS) : CFLAGS += $$(pkg-config --cflags $(libdsme_PC))
-libdsme$(SOVERS) : LDLIBS += $$(pkg-config --libs $(libdsme_PC))
+libdsme$(SOVERS) : override CFLAGS += $$(pkg-config --cflags $(libdsme_PC))
+libdsme$(SOVERS) : override LDLIBS += $$(pkg-config --libs $(libdsme_PC))
libdsme$(SOVERS) : $(libdsme_OBJ)
-libdsme.a : CFLAGS += $$(pkg-config --cflags $(libdsme_PC))
+libdsme.a : override CFLAGS += $$(pkg-config --cflags $(libdsme_PC))
libdsme.a : $(patsubst %.pic.o, %.o, $(libdsme_OBJ))
# ----------------------------------------------------------------------------
@@ -145,6 +145,6 @@ libthermalmanager_dbus_if$(SOVERS) : $(libthermalmanager_dbus_if_OBJ)
ut_libdsme_OBJ += tests/ut_libdsme.o
ut_libdsme_PC += glib-2.0 check
-tests/ut_libdsme : CFLAGS += $$(pkg-config --cflags $(ut_libdsme_PC))
-tests/ut_libdsme : LDLIBS += $$(pkg-config --libs $(ut_libdsme_PC))
+tests/ut_libdsme : override CFLAGS += $$(pkg-config --cflags $(ut_libdsme_PC))
+tests/ut_libdsme : override LDLIBS += $$(pkg-config --libs $(ut_libdsme_PC))
tests/ut_libdsme : $(ut_libdsme_OBJ) libdsme$(SOVERS)
SUMMARY = "Nemomobile's libdsme."
HOMEPAGE = "https://github.com/nemomobile/libdsme.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS += " glib-2.0"
SRC_URI = "git://github.com/nemomobile/libdsme.git;protocol=https \
file://001-Allows-custom-cflags.patch \
"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
do_install() {
oe_runmake install DESTDIR=${D}
}
SUMMARY = "Nemomobile's libiphb."
HOMEPAGE = "https://github.com/nemomobile/libiphb.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/nemomobile/libiphb.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "mcedevel"
inherit autotools pkgconfig
B = "${WORKDIR}/git"
SUMMARY = "Nemomobile's libngf-qt"
HOMEPAGE = "https://github.com/nemomobile/libngf-qt.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/nemomobile/libngf-qt.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " qtbase libngf"
inherit qmake5
do_install_append() {
mv ${D}/lib/* ${D}/usr/lib/
mv ${D}/include/* ${D}/usr/include/
rmdir ${D}/include/
}
SUMMARY = "Nemomobile's libngf"
HOMEPAGE = "https://github.com/nemomobile/libngf.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/nemomobile/libngf.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
SUMMARY = "Nemomobile's libresource"
HOMEPAGE = "https://github.com/mer-packages/libresource"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/mer-packages/libresource;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " dbus-glib"
inherit autotools pkgconfig
commit 0a515a50c2aa1ce0f77563a22c719bfd58ecade7
Author: Florent Revest <revestflo@gmail.com>
Date: Mon Jun 8 14:43:24 2015 +0200
Disables resourceqt-client build
diff --git a/libresourceqt.pro b/libresourceqt.pro
index 1177ab3..7ba2f54 100644
--- a/libresourceqt.pro
+++ b/libresourceqt.pro
@@ -24,11 +24,9 @@ TEMPLATE = subdirs
SUBDIRS = libdbus-qeventloop \
libresourceqt \
libmediaoverridesqt \
- resourceqt-client \
tests
tests.depends = libdbus-qeventloop libresourceqt
-resourceqt-client.depends = libdbus-qeventloop libresourceqt
dist.commands = ./makedist.sh
SUMMARY = "Nemomobile's libresourceqt"
HOMEPAGE = "https://github.com/mer-packages/libresourceqt"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/mer-packages/libresourceqt;protocol=https \
file://001-Disables_resourceqt-client_build.patch"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " qtbase libresource dbus virtual/libgles2"
inherit qmake5
B = "${WORKDIR}/git"
SUMMARY = "Lipstick is a project aimed at offering easy to modify user experiences for varying mobile device form factors, e.g. handsets, netbooks, tablets."
HOMEPAGE = "https://github.com/nemomobile/lipstick"
LICENSE = "LGPL"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = "git://github.com/nemomobile/lipstick.git;protocol=https"
SRC_URI[md5sum] = "d1b7dc2ee09b51192b14083292135c69"
SRC_URI[sha256sum] = "aa8049c9d49bb035f526d19a2bfb7d8e5b78c810946b10dcbd1d02c7a88520e4"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " qtbase qtsensors qtquick1 qtwayland mlite dbus dbus-glib libresourceqt libngf-qt systemd statefs-qt mce usb-moded-qt5"
inherit qmake5
do_configure_prepend() {
sed -i "s/libsystemd-daemon/libsystemd/" ${S}/src/src.pro
sed -i "s/tests doc/tests/" ${S}/lipstick.pro
}
commit e50a224cc64b3caa2e83a22dad8569e0c654b7eb
Author: Florent Revest <revestflo@gmail.com>
Date: Mon Jun 8 01:52:54 2015 +0200
Fixes build with yocto
diff --git a/Makefile b/Makefile
index 731fffb..f1fa87f 100644
--- a/Makefile
+++ b/Makefile
@@ -181,70 +181,70 @@ DBUSCONF := mce.conf
# ----------------------------------------------------------------------------
# C Preprocessor
-CPPFLAGS += -D_GNU_SOURCE
-CPPFLAGS += -DG_DISABLE_DEPRECATED
-CPPFLAGS += -DOSSOLOG_COMPILE
-CPPFLAGS += -DMCE_VAR_DIR=$(VARDIR)
-CPPFLAGS += -DMCE_RUN_DIR=$(RUNDIR)
-CPPFLAGS += -DPRG_VERSION=$(VERSION)
+override CPPFLAGS += -D_GNU_SOURCE
+override CPPFLAGS += -DG_DISABLE_DEPRECATED
+override CPPFLAGS += -DOSSOLOG_COMPILE
+override CPPFLAGS += -DMCE_VAR_DIR=$(VARDIR)
+override CPPFLAGS += -DMCE_RUN_DIR=$(RUNDIR)
+override CPPFLAGS += -DPRG_VERSION=$(VERSION)
ifeq ($(strip $(ENABLE_WAKELOCKS)),y)
-CPPFLAGS += -DENABLE_WAKELOCKS
+override CPPFLAGS += -DENABLE_WAKELOCKS
endif
ifeq ($(strip $(ENABLE_CPU_GOVERNOR)),y)
-CPPFLAGS += -DENABLE_CPU_GOVERNOR
+override CPPFLAGS += -DENABLE_CPU_GOVERNOR
endif
ifeq ($(ENABLE_HYBRIS),y)
-CPPFLAGS += -DENABLE_HYBRIS
+override CPPFLAGS += -DENABLE_HYBRIS
endif
ifeq ($(ENABLE_DOUBLETAP_EMULATION),y)
-CPPFLAGS += -DENABLE_DOUBLETAP_EMULATION
+override CPPFLAGS += -DENABLE_DOUBLETAP_EMULATION
endif
ifeq ($(ENABLE_DEVEL_LOGGING),y)
-CPPFLAGS += -DENABLE_DEVEL_LOGGING
+override CPPFLAGS += -DENABLE_DEVEL_LOGGING
endif
# C Compiler
-CFLAGS += -std=c99
+override CFLAGS += -std=c99
# Do we really need all of these?
-CFLAGS += -Wall
-CFLAGS += -Wextra
-CFLAGS += -Wpointer-arith
-CFLAGS += -Wundef
-CFLAGS += -Wcast-align
-CFLAGS += -Wshadow
-CFLAGS += -Wbad-function-cast
-CFLAGS += -Wwrite-strings
-CFLAGS += -Wsign-compare
-CFLAGS += -Waggregate-return
-CFLAGS += -Wmissing-noreturn
-CFLAGS += -Wnested-externs
-#CFLAGS += -Wchar-subscripts (-Wall does this)
-CFLAGS += -Wmissing-prototypes
-CFLAGS += -Wformat-security
-CFLAGS += -Wformat=2
-CFLAGS += -Wformat-nonliteral
-CFLAGS += -Winit-self
-CFLAGS += -Wswitch-default
-CFLAGS += -Wstrict-prototypes
-CFLAGS += -Wdeclaration-after-statement
-CFLAGS += -Wold-style-definition
-CFLAGS += -Wmissing-declarations
-CFLAGS += -Wmissing-include-dirs
-CFLAGS += -Wstrict-aliasing=2
-CFLAGS += -Wunsafe-loop-optimizations
-CFLAGS += -Winvalid-pch
-#CFLAGS += -Waddress (-Wall does this)
-CFLAGS += -Wvolatile-register-var
-CFLAGS += -Wmissing-format-attribute
-CFLAGS += -Wstack-protector
-#CFLAGS += -Werror (OBS build might have different compiler)
-CFLAGS += -Wno-declaration-after-statement
+override CFLAGS += -Wall
+override CFLAGS += -Wextra
+override CFLAGS += -Wpointer-arith
+override CFLAGS += -Wundef
+override CFLAGS += -Wcast-align
+override CFLAGS += -Wshadow
+override CFLAGS += -Wbad-function-cast
+override CFLAGS += -Wwrite-strings
+override CFLAGS += -Wsign-compare
+override CFLAGS += -Waggregate-return
+override CFLAGS += -Wmissing-noreturn
+override CFLAGS += -Wnested-externs
+#override CFLAGS += -Wchar-subscripts (-Wall does this)
+override CFLAGS += -Wmissing-prototypes
+override CFLAGS += -Wformat-security
+override CFLAGS += -Wformat=2
+override CFLAGS += -Wformat-nonliteral
+override CFLAGS += -Winit-self
+override CFLAGS += -Wswitch-default
+override CFLAGS += -Wstrict-prototypes
+override CFLAGS += -Wdeclaration-after-statement
+override CFLAGS += -Wold-style-definition
+override CFLAGS += -Wmissing-declarations
+override CFLAGS += -Wmissing-include-dirs
+override CFLAGS += -Wstrict-aliasing=2
+override CFLAGS += -Wunsafe-loop-optimizations
+override CFLAGS += -Winvalid-pch
+#override CFLAGS += -Waddress (-Wall does this)
+override CFLAGS += -Wvolatile-register-var
+override CFLAGS += -Wmissing-format-attribute
+override CFLAGS += -Wstack-protector
+#override CFLAGS += -Werror (OBS build might have different compiler)
+override CFLAGS += -Wno-declaration-after-statement
# Linker
LDLIBS += -Wl,--as-needed
@@ -261,9 +261,9 @@ MCE_PKG_NAMES += dbus-1
MCE_PKG_NAMES += dbus-glib-1
MCE_PKG_NAMES += dsme
MCE_PKG_NAMES += libiphb
-MCE_PKG_NAMES += libsystemd-daemon
+MCE_PKG_NAMES += libsystemd
-MCE_PKG_CFLAGS := $(shell $(PKG_CONFIG) --cflags $(MCE_PKG_NAMES))
+MCE_PKG_CFLAGS += $(shell $(PKG_CONFIG) --cflags $(MCE_PKG_NAMES))
MCE_PKG_LDLIBS := $(shell $(PKG_CONFIG) --libs $(MCE_PKG_NAMES))
MCE_CFLAGS += -DMCE_CONF_DIR='"$(CONFDIR)"'
@@ -303,15 +303,15 @@ ifeq ($(strip $(ENABLE_WAKELOCKS)),y)
MCE_CORE += libwakelock.c
endif
-mce : CFLAGS += $(MCE_CFLAGS)
+mce : override CFLAGS += $(MCE_CFLAGS)
mce : LDLIBS += $(MCE_LDLIBS)
ifeq ($(ENABLE_HYBRIS),y)
mce : LDLIBS += -ldl
endif
mce : mce.o $(patsubst %.c,%.o,$(MCE_CORE))
-CFLAGS += -g
-LDFLAGS += -g
+override CFLAGS += -g
+override LDFLAGS += -g
# ----------------------------------------------------------------------------
# MODULES
@@ -334,7 +334,7 @@ MODULE_LDLIBS += $(MODULE_PKG_LDLIBS)
%.pic.o : %.c
$(CC) -c -o $@ $< -fPIC $(CPPFLAGS) $(CFLAGS)
-$(MODULE_DIR)/%.so : CFLAGS += $(MODULE_CFLAGS)
+$(MODULE_DIR)/%.so : override CFLAGS += $(MODULE_CFLAGS)
$(MODULE_DIR)/%.so : LDLIBS += $(MODULE_LDLIBS)
$(MODULE_DIR)/%.so : $(MODULE_DIR)/%.pic.o
$(CC) -shared -o $@ $^ $(LDFLAGS) $(LDLIBS)
@@ -353,11 +353,11 @@ TOOLS_PKG_LDLIBS := $(shell $(PKG_CONFIG) --libs $(TOOLS_PKG_NAMES))
TOOLS_CFLAGS += $(TOOLS_PKG_CFLAGS)
TOOLS_LDLIBS += $(TOOLS_PKG_LDLIBS)
-$(TOOLDIR)/mcetool : CFLAGS += $(TOOLS_CFLAGS)
+$(TOOLDIR)/mcetool : override CFLAGS += $(TOOLS_CFLAGS)
$(TOOLDIR)/mcetool : LDLIBS += $(TOOLS_LDLIBS)
$(TOOLDIR)/mcetool : $(TOOLDIR)/mcetool.o mce-command-line.o
-$(TOOLDIR)/evdev_trace : CFLAGS += $(TOOLS_CFLAGS)
+$(TOOLDIR)/evdev_trace : override CFLAGS += $(TOOLS_CFLAGS)
$(TOOLDIR)/evdev_trace : LDLIBS += $(TOOLS_LDLIBS)
$(TOOLDIR)/evdev_trace : $(TOOLDIR)/evdev_trace.o evdev.o
@@ -380,7 +380,7 @@ UTESTS_LDLIBS += $(UTESTS_PKG_LDLIBS)
UTESTS_CFLAGS += -fdata-sections -ffunction-sections
UTESTS_LDLIBS += -Wl,--gc-sections
-$(UTESTDIR)/% : CFLAGS += $(UTESTS_CFLAGS)
+$(UTESTDIR)/% : override CFLAGS += $(UTESTS_CFLAGS)
$(UTESTDIR)/% : LDLIBS += $(UTESTS_LDLIBS)
$(UTESTDIR)/% : LDLIBS += $(foreach fn_sym,$(LINK_STUBS),\
-Wl,--defsym=$(fn_sym)=stub__$(fn_sym))
SUMMARY = "Nemomobile's MCE."
HOMEPAGE = "https://github.com/nemomobile/mce.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/nemomobile/mce.git;protocol=https \
file://001-Fixes_build.patch"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += " glib-2.0 libdsme libiphb systemd dbus-glib dbus"
do_install() {
oe_runmake install DESTDIR=${D}
}
FILES_${PN}-dbg += "/usr/lib/mce/modules/.debug"
SUMMARY = "Nemomobile's MCE's development files."
HOMEPAGE = "https://github.com/nemomobile/mce-dev.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
SRC_URI = "git://github.com/nemomobile/mce-dev.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
do_install() {
oe_runmake install DESTDIR=${D}
}
SUMMARY = "A light version of meegotouch, pulling in useful parts without requiring the full heavy library."
HOMEPAGE = "https://github.com/nemomobile/mlite.git"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://src/mnotification.cpp;beginline=1;endline=18;md5=5dd5d73b0225b3099a82e6ad93283ea1"
SRC_URI = "git://github.com/nemomobile/mlite.git;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "qtbase"
inherit qmake5
B = "${WORKDIR}/git"
# Out of dir build breaks mlite5.pc installation
From 70443dedff5669e0fcc630dfb7439255e0a3979d Mon Sep 17 00:00:00 2001
From: Simon Busch <morphis@gravedo.de>
Date: Wed, 12 Nov 2014 12:22:19 +0100
Subject: [PATCH 1/2] Unblock rendering for Android 4.4.4 and hwcomposer 1.2
based devices
Signed-off-by: Simon Busch <morphis@gravedo.de>
---
hwcomposer/hwcomposer_backend_v11.cpp | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/hwcomposer/hwcomposer_backend_v11.cpp b/hwcomposer/hwcomposer_backend_v11.cpp
index ee18407..0f10760 100644
--- a/hwcomposer/hwcomposer_backend_v11.cpp
+++ b/hwcomposer/hwcomposer_backend_v11.cpp
@@ -90,9 +90,8 @@ void HWComposer::present(HWComposerNativeWindowBuffer *buffer)
setFenceBufferFd(buffer, fblayer->releaseFenceFd);
- if (oldretire != -1)
- {
- sync_wait(oldretire, -1);
+ if (oldretire != -1) {
+ // sync_wait(oldretire, -1);
close(oldretire);
}
}
--
1.9.1
From de39cca6ed7f3870871554b74873483aa68fb8e7 Mon Sep 17 00:00:00 2001
From: Simon Busch <morphis@gravedo.de>
Date: Wed, 12 Nov 2014 12:21:07 +0100
Subject: [PATCH 2/2] Add QCOM_BSP define switch
Needed as otherwise the structures defined on the android side doesn't match the ones
we're using here.
Signed-off-by: Simon Busch <morphis@gravedo.de>
---
hwcomposer/hwcomposer.pro | 2 ++
1 file changed, 2 insertions(+)
diff --git a/hwcomposer/hwcomposer.pro b/hwcomposer/hwcomposer.pro
index 417f80c..c228926 100644
--- a/hwcomposer/hwcomposer.pro
+++ b/hwcomposer/hwcomposer.pro
@@ -33,6 +33,8 @@ QT += core-private compositor-private gui-private platformsupport-private
DEFINES += QEGL_EXTRA_DEBUG
CONFIG += egl qpa/genericunixfontdatabase
+DEFINES += QCOM_BSP
+
CONFIG += link_pkgconfig
# For linking against libQt5PlatformSupport.a
--
1.9.1
diff --git a/hwcomposer/hwcomposer.pro b/hwcomposer/hwcomposer.pro
index 417f80c..c228926 100644
--- a/hwcomposer/hwcomposer.pro
+++ b/hwcomposer/hwcomposer.pro
@@ -18,9 +18,6 @@
SOURCES += hwcomposer_backend.cpp
HEADERS += hwcomposer_backend.h
-SOURCES += hwcomposer_backend_v0.cpp
-HEADERS += hwcomposer_backend_v0.h
-
SOURCES += hwcomposer_backend_v10.cpp
HEADERS += hwcomposer_backend_v10.h
DESCRIPTION = "This QPA plugin allows rendering on top of libhybris-based hwcomposer EGL \
platforms. The hwcomposer API is specific to a given Droid release, and \
sometimes also SoC type (generic, qcom, exynos4, ...)."
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://hwcomposer_backend.cpp;beginline=1;endline=40;md5=09c08382077db2dbc01b1b5536ec6665"
PV = "5.2.0+gitr${SRCPV}"
DEPENDS = "qtbase libhybris mtdev glib-2.0 udev qtwayland virtual/android-headers"
# We need to be ${MACHINE_ARCH} as we need to compile the source against a specific
# Android version we select per machine
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI = "git://github.com/mer-hybris/qt5-qpa-hwcomposer-plugin.git;protocol=http"
S = "${WORKDIR}/git/hwcomposer"
SRCREV = "${AUTOREV}"
SRC_URI_append_tenderloin = " \
file://0001-Unblock-rendering-for-Android-4.4.4-and-hwcomposer-1.patch;striplevel=2 \
file://0002-Add-QCOM_BSP-define-switch.patch;striplevel=2 \
"
inherit qmake5
# WARNING: The recipe qt5-qpa-hwcomposer-plugin is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
# /OE/build/owpb/webos-ports/tmp-eglibc/sysroots/tenderloin/usr/lib/cmake/Qt5Gui/Qt5Gui_QEglFSIntegrationPlugin.cmake
# Matched in manifest-tenderloin-qtbase.populate_sysroot
# Please verify which package should provide the above files.
do_install_append() {
rm -vf ${D}${libdir}/cmake/Qt5Gui/Qt5Gui_QEglFSIntegrationPlugin.cmake
}
FILES_${PN} += "${libdir}/qt5/plugins/platforms/libhwcomposer.so"
FILES_${PN}-dbg += "${libdir}/qt5/plugins/platforms/.debug/libhwcomposer.so"
FILES_${PN}-dev += "${libdir}/cmake"
SUMMARY = "C++ library providing miscelaneous handy wrappers around Qt classes/functionality. Initially it was created as the port of cutes-js to C++ to port (the-)vault to C++."
HOMEPAGE = "https://github.com/nemomobile/qtaround"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=9d1d95673c01a94e06648bf72ecda12d"
SRC_URI = "git://github.com/nemomobile/qtaround;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "qtbase tut"
inherit cmake_qt5
EXTRA_OECMAKE=" -DVERSION=0.2.6 -DOE_QMAKE_PATH_EXTERNAL_HOST_BINS=${STAGING_DIR_NATIVE}/usr/bin/qt5/"
# Remove dependencies to mesa
PACKAGECONFIG_remove = "kms"
PACKAGECONFIG_remove = "gl"
PACKAGECONFIG_remove = "gles2"
PACKAGECONFIG_append = "mtdev"
PACKAGECONFIG_append = "linuxfb"
commit 7fc6345ef28492954413126be46ecfe5a0eba3c8
Author: Florent Revest <revestflo@gmail.com>
Date: Mon Jun 8 12:44:27 2015 +0200
Disable doc installation
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 064857c..f60a3f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,9 +22,9 @@ link_directories(
${QTAROUND_LIBRARY_DIRS}
)
-add_custom_target(doc
- COMMAND doxygen ${CMAKE_CURRENT_SOURCE_DIR}/doc/Doxyfile)
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/doc/html DESTINATION share/doc/statefs-qt5)
+#add_custom_target(doc
+# COMMAND doxygen ${CMAKE_CURRENT_SOURCE_DIR}/doc/Doxyfile)
+#install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/doc/html DESTINATION share/doc/statefs-qt5)
find_package(Qt5Core REQUIRED)
SUMMARY = "Nemomobile's statefs-qt"
HOMEPAGE = "https://github.com/nemomobile/statefs-qt"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://src/qml/plugin.cpp;beginline=1;endline=6;md5=4f9a52d865013e8cb78d481eaa0e94d7"
SRC_URI = "git://github.com/nemomobile/statefs-qt;protocol=https \
file://001-Disable_doc_installation.patch"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
INSANE_SKIP_statefs-qt += "dev-deps"
DEPENDS += " qtbase cor qtaround"
inherit cmake_qt5
B = "${WORKDIR}/git"
EXTRA_OECMAKE=" -DVERSION=0.2.51 -DOE_QMAKE_PATH_EXTERNAL_HOST_BINS=${STAGING_DIR_NATIVE}/usr/bin/qt5/"
SUMMARY = "TUT is a small and portable unit test framework for C++."
HOMEPAGE = "https://github.com/nemomobile/tut"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=1ed345ec14e0abcb47bf8689dd00eea0"
SRC_URI = "git://github.com/nemomobile/tut;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit waf
do_configure() {
./waf configure --prefix=$prefix --version=0.0.3
}
SUMMARY = "This is a daemon which can hanlde setting different usb profiles with gadget drivers"
HOMEPAGE = "https://github.com/nemomobile/usb-moded"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5f30f0716dfdd0d91eb439ebec522ec2"
SRC_URI = "git://github.com/nemomobile/usb-moded;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
EXTRA_OECONF="--enable-systemd "
do_install_append() {
install -m 644 -D src/usb_moded-dbus.h ${D}/usr/lib//usb_moded-dbus.h
install -m 644 -D src/usb_moded-modes.h %{buildroot}/%{_includedir}/%{name}/usb_moded-modes.h
install -m 644 -D src/usb_moded-appsync-dbus.h %{buildroot}/%{_includedir}/%{name}/usb_moded-appsync-dbus.h
install -m 644 -D src/com.meego.usb_moded.xml %{buildroot}/%{_includedir}/%{name}/com.meego.usb_moded.xml
install -m 644 -D usb_moded.pc %{buildroot}/%{_libdir}/pkgconfig/usb_moded.pc
install -d %{buildroot}/%{_docdir}/%{name}/html/
install -m 644 docs/html/* %{buildroot}/%{_docdir}/%{name}/html/
install -m 644 docs/usb_moded-doc.txt %{buildroot}/%{_docdir}/%{name}/
install -m 644 -D debian/manpage.1 %{buildroot}/%{_mandir}/man1/usb-moded.1
install -m 644 -D debian/usb_moded.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/usb_moded.conf
install -m 644 -D %{SOURCE1} %{buildroot}/%{_sysconfdir}/modprobe.d/usb_moded.conf
install -d %{buildroot}/%{_sysconfdir}/usb-moded
install -d %{buildroot}/%{_sysconfdir}/usb-moded/run
install -d %{buildroot}/%{_sysconfdir}/usb-moded/run-diag
install -d %{buildroot}/%{_sysconfdir}/usb-moded/dyn-modes
install -d %{buildroot}/%{_sysconfdir}/usb-moded/diag
install -m 644 -D config/dyn-modes/* %{buildroot}/%{_sysconfdir}/usb-moded/dyn-modes/
install -m 644 -D config/diag/* %{buildroot}/%{_sysconfdir}/usb-moded/diag/
install -m 644 -D config/run/* %{buildroot}/%{_sysconfdir}/usb-moded/run/
install -m 644 -D config/run-diag/* %{buildroot}/%{_sysconfdir}/usb-moded/run-diag/
install -m 644 -D config/mass-storage-jolla.ini %{buildroot}/%{_sysconfdir}/usb-moded/
touch %{buildroot}/%{_sysconfdir}/modprobe.d/g_ether.conf
touch %{buildroot}/%{_sysconfdir}/udhcpd.conf
#systemd stuff
install -d $RPM_BUILD_ROOT/lib/systemd/system/basic.target.wants/
install -m 644 -D systemd/%{name}.service %{buildroot}/lib/systemd/system/%{name}.service
ln -s ../%{name}.service $RPM_BUILD_ROOT/lib/systemd/system/basic.target.wants/%{name}.service
install -m 644 -D systemd/usb-moded-args.conf %{buildroot}/var/lib/environment/usb-moded/usb-moded-args.conf
install -m 755 -D systemd/turn-usb-rescue-mode-off %{buildroot}/%{_bindir}/turn-usb-rescue-mode-off
install -m 644 -D systemd/usb-rescue-mode-off.service %{buildroot}/lib/systemd/system/usb-rescue-mode-off.service
install -m 644 -D systemd/usb-rescue-mode-off.service %{buildroot}/lib/systemd/system/graphical.target.wants/usb-rescue-mode-off.service
install -m 644 -D systemd/usb-moded.conf %{buildroot}/%{_sysconfdir}/tmpfiles.d/usb-moded.conf
}
SUMMARY = "usb_moded Qt bindings."
HOMEPAGE = "https://github.com/nemomobile/libusb-moded-qt"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://src/qusbmoded.cpp;beginline=1;endline=32;md5=ad12d596c12a6a1ba1d75376dc1f199a"
SRC_URI = "git://github.com/nemomobile/libusb-moded-qt;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
DEPENDS += "qtbase usb-moded"
inherit qmake5
SUMMARY = "This is a daemon which can hanlde setting different usb profiles with gadget drivers"
HOMEPAGE = "https://github.com/nemomobile/usb-moded"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5f30f0716dfdd0d91eb439ebec522ec2"
SRC_URI = "git://github.com/nemomobile/usb-moded;protocol=https"
SRCREV = "${AUTOREV}"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
B = "${WORKDIR}/git"
EXTRA_OECONF="--enable-systemd "
do_configure_prepend() {
sed -i "s@systemd-daemon@systemd@" configure.ac
}
do_install_append() {
install -m 644 -D src/usb_moded-dbus.h ${D}/usr/include/usb-moded/usb_moded-dbus.h
install -m 644 -D src/usb_moded-modes.h ${D}/usr/include/usb-moded/usb_moded-modes.h
install -m 644 -D src/usb_moded-appsync-dbus.h ${D}/usr/include/usb-moded/usb_moded-appsync-dbus.h
install -m 644 -D src/com.meego.usb_moded.xml ${D}/usr/include/usb-moded/com.meego.usb_moded.xml
install -m 644 -D usb_moded.pc ${D}/usr/lib/pkgconfig/usb_moded.pc
install -m 644 -D debian/manpage.1 ${D}/usr/share/man/man1/usb-moded.1
install -m 644 -D debian/usb_moded.conf ${D}/etc/dbus-1/system.d/usb_moded.conf
install -d ${D}/etc/modprobe.d
echo "options g_file_storage stall=0 removable=1" > ${D}/etc/modprobe.d/usb_moded.conf
install -d ${D}/etc/usb-moded
install -d ${D}/etc/usb-moded/run
install -d ${D}/etc/usb-moded/run-diag
install -d ${D}/etc/usb-moded/dyn-modes
install -d ${D}/etc/usb-moded/diag
install -m 644 -D config/dyn-modes/* ${D}/etc/usb-moded/dyn-modes/
install -m 644 -D config/diag/* ${D}/etc/usb-moded/diag/
install -m 644 -D config/run/* ${D}/etc/usb-moded/run/
install -m 644 -D config/run-diag/* ${D}/etc/usb-moded/run-diag/
install -m 644 -D config/mass-storage-jolla.ini ${D}/etc/usb-moded/
touch ${D}/etc/modprobe.d/g_ether.conf
touch ${D}/etc/udhcpd.conf
#systemd stuff
install -d ${D}/lib/systemd/system/basic.target.wants/
install -m 644 -D systemd/usb-moded.service ${D}/lib/systemd/system/usb-moded.service
ln -s ../usb-moded.service ${D}/lib/systemd/system/basic.target.wants/usb-moded.service
install -m 644 -D systemd/usb-moded-args.conf ${D}/var/lib/environment/usb-moded/usb-moded-args.conf
install -m 755 -D systemd/turn-usb-rescue-mode-off ${D}/usr/bin/turn-usb-rescue-mode-off
install -m 644 -D systemd/usb-rescue-mode-off.service ${D}/lib/systemd/system/usb-rescue-mode-off.service
install -m 644 -D systemd/usb-rescue-mode-off.service ${D}/lib/systemd/system/graphical.target.wants/usb-rescue-mode-off.service
install -m 644 -D systemd/usb-moded.conf ${D}/etc/tmpfiles.d/usb-moded.conf
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment