Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
7945bc2a
Commit
7945bc2a
authored
Oct 31, 2016
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
cor: Fix build with GCC 6
parent
d2255fb5
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
29 additions
and
1 deletion
+29
-1
0001-Fix-error-with-GCC-6.patch
recipes-nemomobile/cor/cor/0001-Fix-error-with-GCC-6.patch
+27
-0
cor_git.bb
recipes-nemomobile/cor/cor_git.bb
+2
-1
No files found.
recipes-nemomobile/cor/cor/0001-Fix-error-with-GCC-6.patch
0 → 100644
View file @
7945bc2a
From 6ae25562fb7950755e719060e3642c8a65bb4f5e Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 30 Oct 2016 17:49:03 +0100
Subject: [PATCH] Fix error with GCC 6 caused by an inconsistent usage of
'auto'
---
include/cor/error.hpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/include/cor/error.hpp b/include/cor/error.hpp
index 72fe5d4..645ae75 100644
--- a/include/cor/error.hpp
+++ b/include/cor/error.hpp
@@ -93,7 +93,8 @@
public:
std::copy(&src.frames[0], &src.frames[count_], frames.begin());
if (src.symbols) {
symbols.reset((const char**)calloc(src.count_, sizeof(*symbols)));
- auto to = src.symbols.get(), from = symbols.get();
+ auto to = src.symbols.get();
+ auto from = symbols.get();
std::copy(from, from + count_, to);
}
}
--
2.10.1
recipes-nemomobile/cor/cor_git.bb
View file @
7945bc2a
...
@@ -3,7 +3,8 @@ HOMEPAGE = "https://git.merproject.org/mer-core/cor"
...
@@ -3,7 +3,8 @@ HOMEPAGE = "https://git.merproject.org/mer-core/cor"
LICENSE = "LGPL-2.1+"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d2c621b4dd653efb7cbad641e0a30c59"
LIC_FILES_CHKSUM = "file://COPYING;md5=d2c621b4dd653efb7cbad641e0a30c59"
SRC_URI = "git://git.merproject.org/mer-core/cor.git;protocol=https"
SRC_URI = "git://git.merproject.org/mer-core/cor.git;protocol=https \
file://0001-Fix-error-with-GCC-6.patch"
SRCREV = "52362ca66838694bbfa32071a1c14e1cb0cab1eb"
SRCREV = "52362ca66838694bbfa32071a1c14e1cb0cab1eb"
PR = "r1"
PR = "r1"
PV = "+git${SRCREV}"
PV = "+git${SRCREV}"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment