Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
c0a534d8
Commit
c0a534d8
authored
Dec 26, 2015
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Adds a 'ceres' user that now runs asteroid-launcher and timed-qt5
parent
84991184
Changes
17
Hide whitespace changes
Inline
Side-by-side
Showing
17 changed files
with
125 additions
and
19 deletions
+125
-19
asteroid-image.bbclass
classes/asteroid-image.bbclass
+4
-0
asteroid.conf
conf/distro/asteroid.conf
+1
-1
asteroid-launcher.service
...roid-launcher/asteroid-launcher/asteroid-launcher.service
+2
-2
default.conf
...asteroid/asteroid-launcher/asteroid-launcher/default.conf
+0
-1
asteroid-launcher_git.bb
recipes-asteroid/asteroid-launcher/asteroid-launcher_git.bb
+4
-5
50-video.rules
recipes-core/systemd/systemd/50-video.rules
+2
-0
65-android.rules
recipes-core/systemd/systemd/65-android.rules
+43
-0
dbus.conf
recipes-core/systemd/systemd/dbus.conf
+2
-0
dbus.service
recipes-core/systemd/systemd/dbus.service
+7
-0
dbus.socket
recipes-core/systemd/systemd/dbus.socket
+9
-0
systemd_%.bbappend
recipes-core/systemd/systemd_%.bbappend
+26
-0
lipstick.service
...pes-nemomobile/glacier-home/glacier-home/lipstick.service
+1
-1
glacier-home_git.bb
recipes-nemomobile/glacier-home/glacier-home_git.bb
+3
-4
mapplauncherd-booster-qtcomponents_git.bb
...e/mapplauncherd/mapplauncherd-booster-qtcomponents_git.bb
+5
-0
mapplauncherd-qt_git.bb
recipes-nemomobile/mapplauncherd/mapplauncherd-qt_git.bb
+6
-0
mapplauncherd_git.bb
recipes-nemomobile/mapplauncherd/mapplauncherd_git.bb
+6
-1
timed_git.bb
recipes-nemomobile/timed/timed_git.bb
+4
-4
No files found.
classes/asteroid-image.bbclass
View file @
c0a534d8
inherit core-image
inherit extrausers
LICENSE = "GPL-2.0"
IMAGE_FEATURES += "splash package-management"
...
...
@@ -8,4 +9,7 @@ base-files base-passwd shadow systemd tzdata coreutils bash file findutils gawk
connman bluez5 pulseaudio ppp dropbear qtbase-fonts qtbase-fonts-ttf-dejavu qtbase-plugins statefs dsme mce ngfd timed sensorfw android-init mapplauncherd-booster-qtcomponents \
asteroid-launcher asteroid-calculator asteroid-calendar asteroid-stopwatch"
EXTRA_USERS_PARAMS = "groupadd system; \
useradd -p '' -G 'video,system' ceres"
PACKAGECONFIG_append_pn-qtmultimedia = " gstreamer010"
conf/distro/asteroid.conf
View file @
c0a534d8
...
...
@@ -20,7 +20,7 @@ DISTRO = "asteroid"
DISTRO_NAME
=
"Asteroid"
DISTRO_VERSION
?=
"${DATE}-snapshot"
DISTRO_FEATURES
=
"wayland systemd alsa ipv4 bluetooth bluez5 splash package-management ${DISTRO_FEATURES_LIBC}"
DISTRO_FEATURES
=
"wayland systemd
pam pulseaudio
alsa ipv4 bluetooth bluez5 splash package-management ${DISTRO_FEATURES_LIBC}"
PREFERRED_PROVIDER_jpeg
=
"libjpeg-turbo"
PREFERRED_PROVIDER_jpeg
-
native
=
"libjpeg-turbo-native"
...
...
recipes-asteroid/asteroid-launcher/asteroid-launcher/asteroid-launcher.service
View file @
c0a534d8
[Unit]
Description=The
lipstick UI
Description=The
wayland compositors and desktop of AsteroidOS
Requires=dbus.socket
[Service]
...
...
@@ -11,4 +11,4 @@ ExecStart=/usr/bin/lipstick $LIPSTICK_OPTIONS --systemd
Restart=always
[Install]
WantedBy=
multi-user
.target
WantedBy=
default
.target
recipes-asteroid/asteroid-launcher/asteroid-launcher/default.conf
View file @
c0a534d8
EGL_PLATFORM
=
hwcomposer
XDG_RUNTIME_DIR
=/
tmp
LIPSTICK_OPTIONS
=
"-plugin evdevtouch:/dev/input/event0 -platform hwcomposer"
recipes-asteroid/asteroid-launcher/asteroid-launcher_git.bb
View file @
c0a534d8
...
...
@@ -14,14 +14,13 @@ inherit qmake5
DEPENDS += "lipstick"
RDEPENDS_${PN} += "qtdeclarative-qmlplugins qtquickcontrols-qmlplugins qml-asteroid qtwayland-plugins qtgraphicaleffects-qmlplugins nemo-qml-plugin-time nemo-qml-plugin-contextkit nemo-qml-plugin-configuration libconnman-qt xkeyboard-config"
FILES_${PN} += "/usr/share/asteroid-launcher/ /
lib/systemd/system
"
FILES_${PN} += "/usr/share/asteroid-launcher/ /
usr/lib/systemd/user/
"
do_install_append() {
install -d ${D}/var/lib/environment/compositor/
cp ../default.conf ${D}/var/lib/environment/compositor/
# TODO: This should definitely be run as a simple user !!
install -d ${D}/lib/systemd/system/multi-user.target.wants/
cp ../asteroid-launcher.service ${D}/lib/systemd/system/
ln -s ../asteroid-launcher.service ${D}/lib/systemd/system/multi-user.target.wants/asteroid-launcher.service
install -d ${D}/usr/lib/systemd/user/default.target.wants/
cp ../asteroid-launcher.service ${D}/usr/lib/systemd/user/
ln -s ../asteroid-launcher.service ${D}/usr/lib/systemd/user/default.target.wants/asteroid-launcher.service
}
recipes-core/systemd/systemd/50-video.rules
0 → 100644
View file @
c0a534d8
ACTION=="add", KERNEL=="ion", MODE="0664", GROUP="video"
ACTION=="add", KERNEL=="kgsl-3d0", MODE="0664", GROUP="video"
recipes-core/systemd/systemd/65-android.rules
0 → 100644
View file @
c0a534d8
# Taken from https://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/
# lxc-android-config/saucy/view/head:/lib/udev/rules.d/65-android.rules
# (c) 2013 Canonical LTD.
#
# This program is free software: you can redistribute it and/or modify it
# under the terms of the the GNU General Public License version 3, as
# published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranties of
# MERCHANTABILITY, SATISFACTORY QUALITY or FITNESS FOR A PARTICULAR
# PURPOSE. See the applicable version of the GNU Lesser General Public
# License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
# logging devices
ACTION=="add", KERNEL=="log_*", MODE="0666"
ACTION=="add", KERNEL=="log_main", SYMLINK+="alog/main"
ACTION=="add", KERNEL=="log_system", SYMLINK+="alog/system"
ACTION=="add", KERNEL=="log_radio", SYMLINK+="alog/radio"
ACTION=="add", KERNEL=="log_events", SYMLINK+="alog/events"
# system devices
ACTION=="add", KERNEL=="binder", MODE="0666"
# graphics devices
SUBSYSTEM=="graphics", KERNEL=="*", SYMLINK+="graphics/%k"
# input devices
ACTION=="add", KERNEL=="event[0-9]*", GROUP="system", MODE="0660"
# misc devices
ACTION=="add", KERNEL=="alarm", GROUP="system", MODE="0664"
ACTION=="add", KERNEL=="uhid", GROUP="system", MODE="0660"
# memory
ACTION=="add", KERNEL=="ashmem", GROUP="system", MODE="0666"
# rfkill
ACTION=="add", KERNEL=="rfkill", GROUP="system", MODE="0660"
recipes-core/systemd/systemd/dbus.conf
0 → 100644
View file @
c0a534d8
[
Service
]
Environment
=
DBUS_SESSION_BUS_ADDRESS
=
unix
:
path
=/
run
/
user
/%
I
/
dbus
/
user_bus_socket
recipes-core/systemd/systemd/dbus.service
0 → 100644
View file @
c0a534d8
[Unit]
Description=D-Bus Message Bus
Requires=dbus.socket
[Service]
ExecStart=/usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
ExecReload=/usr/bin/dbus-send --print-reply --session --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig
recipes-core/systemd/systemd/dbus.socket
0 → 100644
View file @
c0a534d8
[Unit]
Description=D-Bus Message Bus Socket
Before=sockets.target
[Socket]
ListenStream=%t/dbus/user_bus_socket
[Install]
WantedBy=default.target
recipes-core/systemd/systemd_%.bbappend
0 → 100644
View file @
c0a534d8
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append = "file://50-video.rules \
file://65-android.rules \
file://dbus.service \
file://dbus.socket \
file://dbus.conf"
do_install_append() {
# Setup udev rules for the rights of Android and graphic cards specific devices
install -m 0644 ${WORKDIR}/50-video.rules ${D}${sysconfdir}/udev/rules.d/50-video.rules
install -m 0644 ${WORKDIR}/65-android.rules ${D}${sysconfdir}/udev/rules.d/65-android.rules
# Enables auto-login for ceres
sed -i "s@agetty --noclear @agetty --autologin ceres @" ${D}/lib/systemd/system/getty@.service
# In current systemd versions we have to take care ourselves of the dbus user service, it should be handled in the next versions
install -d ${D}/usr/lib/systemd/user/default.target.wants/
install -m 0644 ${WORKDIR}/dbus.socket ${D}/usr/lib/systemd/user/dbus.socket
install -m 0644 ${WORKDIR}/dbus.service ${D}/usr/lib/systemd/user/dbus.service
ln -s ../dbus.socket ${D}/usr/lib/systemd/user/default.target.wants/dbus.socket
ln -s ../dbus.service ${D}/usr/lib/systemd/user/default.target.wants/dbus.service
install -d ${D}/etc/systemd/system/user@.service.d/
install -m 0644 ${WORKDIR}/dbus.conf ${D}/etc/systemd/system/user@.service.d/dbus.conf
}
PACKAGECONFIG_append += "pam"
recipes-nemomobile/glacier-home/glacier-home/lipstick.service
View file @
c0a534d8
...
...
@@ -11,4 +11,4 @@ ExecStart=/usr/bin/lipstick $LIPSTICK_OPTIONS --systemd
Restart=always
[Install]
WantedBy=
multi-user
.target
WantedBy=
default
.target
recipes-nemomobile/glacier-home/glacier-home_git.bb
View file @
c0a534d8
...
...
@@ -20,8 +20,7 @@ do_install_append() {
install -d ${D}/var/lib/environment/compositor/
cp ../default.conf ${D}/var/lib/environment/compositor/
# TODO: This should definitely be run as a simple user !!
install -d ${D}/lib/systemd/system/multi-user.target.wants/
cp ../lipstick.service ${D}/lib/systemd/system/
ln -s ../lipstick.service ${D}/lib/systemd/system/multi-user.target.wants/lipstick.service
install -d ${D}/usr/lib/systemd/user/default.target.wants/
cp ../lipstick.service ${D}/usr/lib/systemd/user/
ln -s ../lipstick.service ${D}/usr/lib/systemd/user/default.target.wants/lipstick.service
}
recipes-nemomobile/mapplauncherd/mapplauncherd-booster-qtcomponents_git.bb
View file @
c0a534d8
...
...
@@ -17,5 +17,10 @@ do_configure_prepend() {
sed -i "s@LIBS += -lapplauncherd@LIBS += -lapplauncherd -lmdeclarativecache5@" ${S}/booster-qtcomponents.pro
}
do_install_append() {
install -d ${D}/usr/lib/systemd/user/default.target.wants/
# ln -s ../booster-qtcomponents-qt5.service ${D}/usr/lib/systemd/user/default.target.wants/booster-qtcomponents-qt5.service
}
FILES_${PN} += "/usr/libexec/mapplauncherd/ /usr/lib/systemd/user /usr/share/booster-qtcomponents-qt5"
FILES_${PN}-dbg += "/usr/libexec/mapplauncherd/.debug"
recipes-nemomobile/mapplauncherd/mapplauncherd-qt_git.bb
View file @
c0a534d8
...
...
@@ -16,5 +16,11 @@ do_configure_prepend() {
sed -i "s@INCLUDEPATH += /usr/include/applauncherd@INCLUDEPATH += ${STAGING_INCDIR}/applauncherd@" ${S}/qtbooster/qtbooster.pro
}
do_install_append() {
install -d ${D}/usr/lib/systemd/user/default.target.wants/
# ln -s ../booster-qt5.service ${D}/usr/lib/systemd/user/default.target.wants/booster-qt5.service
# ln -s ../booster-qt5-signal.service ${D}/usr/lib/systemd/user/default.target.wants/booster-qt5-signal.service
}
FILES_${PN} += "/usr/share/mkspecs/features /usr/lib/systemd/user /usr/libexec/mapplauncherd"
FILES_${PN}-dbg += "/usr/libexec/mapplauncherd/.debug"
recipes-nemomobile/mapplauncherd/mapplauncherd_git.bb
View file @
c0a534d8
...
...
@@ -19,5 +19,10 @@ do_configure_prepend() {
sed -i 's@lsystemd-daemon@lsystemd@' ${S}/src/launcherlib/CMakeLists.txt
}
FILES_${PN} += "/usr/lib/systemd /usr/libexec/mapplauncherd/"
do_install_append() {
install -d ${D}/usr/lib/systemd/user/default.target.wants/
# ln -s ../booster-generic.service ${D}/usr/lib/systemd/user/default.target.wants/booster-generic.service
}
FILES_${PN} += "/usr/lib/systemd/user /usr/libexec/mapplauncherd/"
FILES_${PN}-dbg += "/usr/libexec/mapplauncherd/.debug"
recipes-nemomobile/timed/timed_git.bb
View file @
c0a534d8
...
...
@@ -17,16 +17,16 @@ B = "${S}"
do_configure_prepend() {
mkdir -p src/h/timed-qt5/
cp src/lib/qmacro.h src/h/timed-qt5/qmacro.h
sed -i "s@<policy user=\"nemo\">@<policy user=\"
root
\">@" src/server/timed-qt5.conf src/server/timed.conf tests/ut_networktime/fakeofono/org.fakeofono.conf
sed -i "s@<policy user=\"nemo\">@<policy user=\"
ceres
\">@" src/server/timed-qt5.conf src/server/timed.conf tests/ut_networktime/fakeofono/org.fakeofono.conf
}
do_install_append() {
install -d ${D}/
lib/systemd/system
/
mv ${D}/usr/lib/systemd/user/timed-qt5.service ${D}/lib/systemd/system/timed-qt5.service
install -d ${D}/
usr/lib/systemd/user/default.target.wants
/
ln -s ../timed-qt5.service ${D}/usr/lib/systemd/user/default.target.wants/timed-qt5.service
}
DEPENDS += "pcre systemd tzdata libiodata-native libiodata statefs-qt qtbase"
FILES_${PN} += "/usr/lib/ /usr/share/contextkit
/lib/
"
FILES_${PN} += "/usr/lib/ /usr/share/contextkit"
FILES_${PN}-dev += "/usr/share/mkspecs"
FILES_${PN}-dbg += "/opt"
INSANE_SKIP_${PN} += "dev-deps"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment