Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
d73c4d24
Commit
d73c4d24
authored
Feb 28, 2017
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Upgrade lipstick to a fork that supports Qt 5.8
parent
5b7809bc
Changes
6
Hide whitespace changes
Inline
Side-by-side
Showing
6 changed files
with
27 additions
and
301 deletions
+27
-301
0001-Disables-tests-and-doc.patch
...obile/lipstick/lipstick/0001-Disables-tests-and-doc.patch
+23
-0
0001-Disables-tests-tools-and-doc-and-fixes-build.patch
...k/0001-Disables-tests-tools-and-doc-and-fixes-build.patch
+0
-181
0002-Store-notifications-database-inside-cere-s-home-dire.patch
...tore-notifications-database-inside-cere-s-home-dire.patch
+0
-25
0003-Fix-build-with-no-accessibility.patch
...stick/lipstick/0003-Fix-build-with-no-accessibility.patch
+0
-63
0005-Add-a-missing-math.h-include.patch
...lipstick/lipstick/0005-Add-a-missing-math.h-include.patch
+0
-25
lipstick_git.bb
recipes-nemomobile/lipstick/lipstick_git.bb
+4
-7
No files found.
recipes-nemomobile/lipstick/lipstick/0001-Disables-tests-and-doc.patch
0 → 100644
View file @
d73c4d24
From d1701f01b300319c2c4a9e6cb7e891d8a68d1192 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Tue, 28 Feb 2017 12:40:30 +0100
Subject: [PATCH] Disables tests and doc
---
lipstick.pro | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lipstick.pro b/lipstick.pro
index 78ee362d..28f07219 100644
--- a/lipstick.pro
+++ b/lipstick.pro
@@ -1,5 +1,5 @@
TEMPLATE = subdirs
-SUBDIRS += src plugin tools tests doc
+SUBDIRS += src plugin tools
plugin.depends = src
tools.depends = src
--
2.11.0
recipes-nemomobile/lipstick/lipstick/0001-Disables-tests-tools-and-doc-and-fixes-build.patch
deleted
100644 → 0
View file @
5b7809bc
From 0a19efd68b4f116fab38158f15d64e6686453810 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sat, 16 Jan 2016 17:06:23 +0100
Subject: [PATCH] Disables tests, tools and doc and fixes build
---
lipstick.pro | 2 +-
src/compositor/hwcrenderstage.h | 3 ++-
src/compositor/lipstickcompositor.cpp | 10 +++++-----
src/compositor/lipstickcompositor.h | 3 ++-
src/compositor/lipstickcompositorwindow.cpp | 2 +-
src/compositor/windowmodel.cpp | 2 +-
src/notifications/lipsticknotification.cpp | 1 +
src/src.pro | 2 +-
tools/screenshottool/screenshottool.pro | 1 -
9 files changed, 14 insertions(+), 12 deletions(-)
diff --git a/lipstick.pro b/lipstick.pro
index 78ee362..28f0721 100644
--- a/lipstick.pro
+++ b/lipstick.pro
@@ -1,5 +1,5 @@
TEMPLATE = subdirs
-SUBDIRS += src plugin tools tests doc
+SUBDIRS += src plugin tools
plugin.depends = src
tools.depends = src
diff --git a/src/compositor/hwcrenderstage.h b/src/compositor/hwcrenderstage.h
index e535f81..cbd1f09 100644
--- a/src/compositor/hwcrenderstage.h
+++ b/src/compositor/hwcrenderstage.h
@@ -17,6 +17,7 @@
#define HWCRENDERSTAGE
#include <private/qquickwindow_p.h>
+#include <private/qsgrenderer_p.h>
Q_DECLARE_LOGGING_CATEGORY(LIPSTICK_LOG_HWC)
@@ -130,4 +131,4 @@
private:
static bool m_hwcEnabled;
};
-#endif // HWCRENDERSTAGE
\
No newline at end of file
+#endif // HWCRENDERSTAGE
diff --git a/src/compositor/lipstickcompositor.cpp b/src/compositor/lipstickcompositor.cpp
index bf2f0e9..d750e6e 100644
--- a/src/compositor/lipstickcompositor.cpp
+++ b/src/compositor/lipstickcompositor.cpp
@@ -41,8 +41,7 @@
LipstickCompositor *LipstickCompositor::m_instance = 0;
LipstickCompositor::LipstickCompositor()
- : QWaylandQuickCompositor(this, 0, (QWaylandCompositor::ExtensionFlags)QWaylandCompositor::DefaultExtensions & ~QWaylandCompositor::QtKeyExtension)
- , m_totalWindowCount(0)
+ : m_totalWindowCount(0)
, m_nextWindowId(1)
, m_homeActive(true)
, m_shaderEffect(0)
@@ -64,6 +63,7 @@
LipstickCompositor::LipstickCompositor()
{
setColor(Qt::black);
setRetainedSelectionEnabled(true);
+ createOutput(this, "", "");
addDefaultShell();
if (m_instance) qFatal("LipstickCompositor: Only one compositor instance per process is supported");
@@ -183,7 +183,7 @@
void LipstickCompositor::surfaceCreated(QWaylandSurface *surface)
connect(surface, &QWaylandSurface::redraw, this, &LipstickCompositor::surfaceCommitted);
}
-bool LipstickCompositor::openUrl(WaylandClient *client, const QUrl &url)
+bool LipstickCompositor::openUrl(QWaylandClient *client, const QUrl &url)
{
Q_UNUSED(client)
return openUrl(url);
@@ -286,7 +286,7 @@
int LipstickCompositor::windowIdForLink(QWaylandSurface *s, uint link) const
QWaylandSurface *windowSurface = iter.value()->surface();
if (windowSurface && windowSurface->client() && s->client() &&
- windowSurface->processId() == s->processId() &&
+ windowSurface->client()->processId() == s->client()->processId() &&
windowSurface->windowProperties().value("WINID", uint(0)).toUInt() == link)
return iter.value()->windowId();
}
@@ -357,7 +357,7 @@
void LipstickCompositor::setTopmostWindowId(int id)
QWaylandSurface *surface = surfaceForId(m_topmostWindowId);
if (surface)
- pid = surface->processId();
+ pid = surface->client()->processId();
if (m_topmostWindowProcessId != pid) {
m_topmostWindowProcessId = pid;
diff --git a/src/compositor/lipstickcompositor.h b/src/compositor/lipstickcompositor.h
index e3db6b1..33be214 100644
--- a/src/compositor/lipstickcompositor.h
+++ b/src/compositor/lipstickcompositor.h
@@ -21,6 +21,7 @@
#include <QQmlParserStatus>
#include <QWaylandQuickCompositor>
#include <QWaylandSurfaceItem>
+#include <QWaylandClient>
#include <QPointer>
#include <QTimer>
#include <MGConfItem>
@@ -64,7 +65,7 @@
public:
void classBegin() Q_DECL_OVERRIDE;
void componentComplete() Q_DECL_OVERRIDE;
void surfaceCreated(QWaylandSurface *surface) Q_DECL_OVERRIDE;
- bool openUrl(WaylandClient *client, const QUrl &url) Q_DECL_OVERRIDE;
+ bool openUrl(QWaylandClient *client, const QUrl &url) Q_DECL_OVERRIDE;
void retainedSelectionReceived(QMimeData *mimeData) Q_DECL_OVERRIDE;
int windowCount() const;
diff --git a/src/compositor/lipstickcompositorwindow.cpp b/src/compositor/lipstickcompositorwindow.cpp
index bab4c42..a9c21ca 100644
--- a/src/compositor/lipstickcompositorwindow.cpp
+++ b/src/compositor/lipstickcompositorwindow.cpp
@@ -77,7 +77,7 @@
int LipstickCompositorWindow::windowId() const
qint64 LipstickCompositorWindow::processId() const
{
if (surface())
- return surface()->processId();
+ return surface()->client()->processId();
else return 0;
}
diff --git a/src/compositor/windowmodel.cpp b/src/compositor/windowmodel.cpp
index 7ecd4d4..03c5b82 100644
--- a/src/compositor/windowmodel.cpp
+++ b/src/compositor/windowmodel.cpp
@@ -68,7 +68,7 @@
QVariant WindowModel::data(const QModelIndex &index, int role) const
return m_items.at(idx);
} else if (role == Qt::UserRole + 2) {
QWaylandSurface *s = c->surfaceForId(m_items.at(idx));
- return s?s->processId():0;
+ return s?s->client()->processId():0;
} else if (role == Qt::UserRole + 3) {
LipstickCompositorWindow *w = static_cast<LipstickCompositorWindow *>(c->windowForId(m_items.at(idx)));
return w->title();
diff --git a/src/notifications/lipsticknotification.cpp b/src/notifications/lipsticknotification.cpp
index 3b18a13..af6d607 100644
--- a/src/notifications/lipsticknotification.cpp
+++ b/src/notifications/lipsticknotification.cpp
@@ -18,6 +18,7 @@
#include <QDBusArgument>
#include <QtDebug>
+#include <QDataStream>
LipstickNotification::LipstickNotification(const QString &appName, uint replacesId, const QString &appIcon, const QString &summary, const QString &body, const QStringList &actions, const QVariantHash &hints, int expireTimeout, QObject *parent) :
QObject(parent),
diff --git a/src/src.pro b/src/src.pro
index 5e66ecb..f8d4ff1 100644
--- a/src/src.pro
+++ b/src/src.pro
@@ -139,7 +139,7 @@
SOURCES += \
CONFIG += link_pkgconfig mobility qt warn_on depend_includepath qmake_cache target_qt
CONFIG -= link_prl
-PKGCONFIG += mlite5 mce keepalive dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 Qt5SystemInfo libsystemd-daemon contextkit-statefs dsme_dbus_if thermalmanager_dbus_if usb-moded-qt5
+PKGCONFIG += mlite5 mce keepalive dbus-1 dbus-glib-1 libresourceqt5 ngf-qt5 Qt5SystemInfo libsystemd contextkit-statefs dsme_dbus_if thermalmanager_dbus_if usb-moded-qt5 egl
LIBS += -lrt
diff --git a/tools/screenshottool/screenshottool.pro b/tools/screenshottool/screenshottool.pro
index 0a8cf23..d666850 100644
--- a/tools/screenshottool/screenshottool.pro
+++ b/tools/screenshottool/screenshottool.pro
@@ -1,5 +1,4 @@
TEMPLATE = subdirs
-SUBDIRS = application
screenshottool.files = screenshottool
screenshottool.path = /usr/bin
--
2.9.3
recipes-nemomobile/lipstick/lipstick/0002-Store-notifications-database-inside-cere-s-home-dire.patch
deleted
100644 → 0
View file @
5b7809bc
From ced56479a1ed6a70ed9678671cea86a30a971596 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Mon, 6 Jun 2016 17:13:57 +0200
Subject: [PATCH] Store notifications database inside cere's home directory
---
src/notifications/notificationmanager.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/notifications/notificationmanager.cpp b/src/notifications/notificationmanager.cpp
index f9d3a33..67f5e91 100644
--- a/src/notifications/notificationmanager.cpp
+++ b/src/notifications/notificationmanager.cpp
@@ -605,7 +605,7 @@
void NotificationManager::restoreNotifications(bool update)
bool NotificationManager::connectToDatabase()
{
- QString databasePath = "/home/nemo" + QString(PRIVILEGED_DATA_PATH) + QDir::separator() + "Notifications";
+ QString databasePath = "/home/ceres" + QString(PRIVILEGED_DATA_PATH) + QDir::separator() + "Notifications";
if (!QDir::root().exists(databasePath)) {
QDir::root().mkpath(databasePath);
}
--
2.8.1
recipes-nemomobile/lipstick/lipstick/0003-Fix-build-with-no-accessibility.patch
deleted
100644 → 0
View file @
5b7809bc
From 3388c954e7fe9a7fbc7e11817e55e208ac3a8e5a Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Mon, 12 Sep 2016 22:48:08 +0200
Subject: [PATCH] Fix build with no-accessibility
---
src/compositor/hwcimage.cpp | 1 +
src/compositor/lipstickrecorder.cpp | 1 +
src/compositor/windowmodel.cpp | 1 +
src/homewindow.cpp | 1 +
4 files changed, 4 insertions(+)
diff --git a/src/compositor/hwcimage.cpp b/src/compositor/hwcimage.cpp
index 25ee330..cbbccb7 100644
--- a/src/compositor/hwcimage.cpp
+++ b/src/compositor/hwcimage.cpp
@@ -18,6 +18,7 @@
#include <QRunnable>
#include <QThreadPool>
+#include <QCoreApplication>
#include <QQuickWindow>
#include <QSGSimpleTextureNode>
diff --git a/src/compositor/lipstickrecorder.cpp b/src/compositor/lipstickrecorder.cpp
index a758363..5e94686 100644
--- a/src/compositor/lipstickrecorder.cpp
+++ b/src/compositor/lipstickrecorder.cpp
@@ -16,6 +16,7 @@
#include <sys/time.h>
#include <grp.h>
+#include <QCoreApplication>
#include <QMutexLocker>
#include "lipstickrecorder.h"
diff --git a/src/compositor/windowmodel.cpp b/src/compositor/windowmodel.cpp
index 7ecd4d4..102fc45 100644
--- a/src/compositor/windowmodel.cpp
+++ b/src/compositor/windowmodel.cpp
@@ -14,6 +14,7 @@
****************************************************************************/
#include <QDBusConnection>
+#include <QDebug>
#include "lipstickcompositorwindow.h"
#include "lipstickcompositor.h"
#include "windowmodel.h"
diff --git a/src/homewindow.cpp b/src/homewindow.cpp
index b59e668..2d33bbd 100644
--- a/src/homewindow.cpp
+++ b/src/homewindow.cpp
@@ -20,6 +20,7 @@
#include <QQuickView>
#include <QQmlContext>
#include <QGuiApplication>
+#include <QDebug>
#include "homeapplication.h"
#include "compositor/lipstickcompositorprocwindow.h"
#include "compositor/lipstickcompositor.h"
--
2.9.3
recipes-nemomobile/lipstick/lipstick/0005-Add-a-missing-math.h-include.patch
deleted
100644 → 0
View file @
5b7809bc
From 7b73acdc5e10c3d4ffc0219504698bf4f489157b Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 30 Oct 2016 21:52:00 +0100
Subject: [PATCH] Add a missing math.h include
---
src/compositor/hwcimage.cpp | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/compositor/hwcimage.cpp b/src/compositor/hwcimage.cpp
index 25ee330..24a7364 100644
--- a/src/compositor/hwcimage.cpp
+++ b/src/compositor/hwcimage.cpp
@@ -28,6 +28,8 @@
#include <EGL/egl.h>
#include <EGL/eglext.h>
+#include <math.h>
+
static bool hwcimage_is_enabled();
#define HWCIMAGE_LOAD_EVENT ((QEvent::Type) (QEvent::User + 1))
--
2.10.1
recipes-nemomobile/lipstick/lipstick_git.bb
View file @
d73c4d24
...
...
@@ -3,13 +3,10 @@ HOMEPAGE = "https://git.merproject.org/mer-core/lipstick"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = "git://git.merproject.org/mer-core/lipstick.git;protocol=https \
file://0001-Disables-tests-tools-and-doc-and-fixes-build.patch \
file://0002-Store-notifications-database-inside-cere-s-home-dire.patch \
file://0003-Fix-build-with-no-accessibility.patch \
file://0004-notificationcategories-use-ion-icons.patch \
file://0005-Add-a-missing-math.h-include.patch"
SRCREV = "d393a948d2d7d179dbe5dedf3ae68543e655507a"
SRC_URI = "git://github.com/AsteroidOS/lipstick.git;protocol=https \
file://0001-Disables-tests-and-doc.patch \
file://0004-notificationcategories-use-ion-icons.patch"
SRCREV = "0274da621e9a26b1386c624fc841fcae89a3f3ac"
PR = "r1"
PV = "+git${SRCREV}"
S = "${WORKDIR}/git"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment