Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
e500bb6b
Commit
e500bb6b
authored
Feb 20, 2018
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
Adds a libmlocale recipe needed by nemo-qml-plugin-models
parent
59e60c05
Changes
5
Hide whitespace changes
Inline
Side-by-side
Showing
5 changed files
with
143 additions
and
0 deletions
+143
-0
0001-MIcuConversions-Cast-a-pointer-with-reinterpret_cast.patch
...IcuConversions-Cast-a-pointer-with-reinterpret_cast.patch
+40
-0
0002-Disable-a-faulty-chinese-collision-text-building.patch
...02-Disable-a-faulty-chinese-collision-text-building.patch
+25
-0
0003-Disable-tests-and-doc.patch
...le/libmlocale/libmlocale/0003-Disable-tests-and-doc.patch
+27
-0
0004-configure-Use-a-usr-prefix-by-default.patch
...bmlocale/0004-configure-Use-a-usr-prefix-by-default.patch
+25
-0
libmlocale_git.bb
recipes-nemomobile/libmlocale/libmlocale_git.bb
+26
-0
No files found.
recipes-nemomobile/libmlocale/libmlocale/0001-MIcuConversions-Cast-a-pointer-with-reinterpret_cast.patch
0 → 100644
View file @
e500bb6b
From 92cf10751f0c4262cd7dc46bf0214bfc0d9416d7 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Tue, 20 Feb 2018 14:00:34 +0100
Subject: [PATCH] MIcuConversions: Cast a pointer with reinterpret_cast instead
of static_cast
---
src/micuconversions.cpp | 2 +-
tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/micuconversions.cpp b/src/micuconversions.cpp
index dd04aad3..046ea8be 100644
--- a/src/micuconversions.cpp
+++ b/src/micuconversions.cpp
@@ -30,7 +30,7 @@
namespace ML10N {
icu::UnicodeString MIcuConversions::qStringToUnicodeString(const QString &sourceStr)
{
- return UnicodeString(static_cast<const UChar *>(sourceStr.utf16()),
+ return UnicodeString(reinterpret_cast<const UChar *>(sourceStr.utf16()),
sourceStr.length());
}
diff --git a/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp b/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
index 48a2445d..dd969cbd 100644
--- a/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
+++ b/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
@@ -670,7 +670,7 @@
void Ut_MLocationDatabase::testCitiesDumpInfo()
foreach(MCity city, cities) {
UErrorCode status = U_ZERO_ERROR;
icu::UnicodeString canonicalId;
- icu::UnicodeString id = static_cast<const UChar *>(city.timeZone().utf16());
+ icu::UnicodeString id = reinterpret_cast<const UChar *>(city.timeZone().utf16());
TimeZone::getCanonicalID (id, canonicalId, status);
QString cityCanonicalTimeZoneICU =
QString(reinterpret_cast<const QChar *>(canonicalId.getBuffer()), canonicalId.length());
--
2.14.3
recipes-nemomobile/libmlocale/libmlocale/0002-Disable-a-faulty-chinese-collision-text-building.patch
0 → 100644
View file @
e500bb6b
From 4c86e6e719e1d7d7f9789a9d21b1365b35b7b284 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Tue, 20 Feb 2018 14:01:19 +0100
Subject: [PATCH] Disable a faulty chinese collision text building
---
src/icu-extradata/icu-extradata.pro | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/icu-extradata/icu-extradata.pro b/src/icu-extradata/icu-extradata.pro
index 0d5756f3..1d26fe0d 100644
--- a/src/icu-extradata/icu-extradata.pro
+++ b/src/icu-extradata/icu-extradata.pro
@@ -134,7 +134,7 @@
greaterThan(ICUVERSION, 4.4) {
data/lang/pt_PT.txt \
data/lang/zh.txt \
data/lang/zh_Hant.txt
- COLLTXT = data/coll/zh.txt \
+ COLLTXT = \
data/coll/be.txt \
data/coll/bg.txt \
data/coll/kk.txt \
--
2.14.3
recipes-nemomobile/libmlocale/libmlocale/0003-Disable-tests-and-doc.patch
0 → 100644
View file @
e500bb6b
From 9fc0e12131816cc73b12cb6050ecd570f4bdc243 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Tue, 20 Feb 2018 14:17:51 +0100
Subject: [PATCH] Disable tests and doc
---
projects.pro | 3 ---
1 file changed, 3 deletions(-)
diff --git a/projects.pro b/projects.pro
index 478c5840..a4950cdc 100644
--- a/projects.pro
+++ b/projects.pro
@@ -24,10 +24,7 @@
SUBDIRS += \
src \
src/icu-extradata \
benchmarks \
- tests \
-# Docs are always explicitly built with "make doc"
-include(doc/doc.pri)
check.target = check
check.CONFIG = recursive
--
2.14.3
recipes-nemomobile/libmlocale/libmlocale/0004-configure-Use-a-usr-prefix-by-default.patch
0 → 100644
View file @
e500bb6b
From 5efb61a37ffb71a563e17d2189784a474f7d7ac9 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Tue, 20 Feb 2018 14:31:55 +0100
Subject: [PATCH] configure: Use a /usr/ prefix by default
---
configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
index 316a4153..571179af 100755
--- a/configure
+++ b/configure
@@ -71,7 +71,7 @@
OPT_SHADOW=maybe
IS_ARMEL=no
# initalize variables used for installation
-M_INSTALL_PREFIX=/usr/local
+M_INSTALL_PREFIX=/usr
M_INSTALL_SYSCONFDIR=/etc
M_INSTALL_LIBDIR= # Will be $M_INSTALL_PREFIX/lib unless overriden
--
2.14.3
recipes-nemomobile/libmlocale/libmlocale_git.bb
0 → 100644
View file @
e500bb6b
SUMMARY = "Meego Locale library"
HOMEPAGE = "https://git.merproject.org/mer-core/libmlocale"
LICENSE = "LGPL-2.1+"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=7635eef25dff78f483059bf21a20686d"
SRC_URI = "git://git.merproject.org/mer-core/libmlocale.git;protocol=https \
file://0001-MIcuConversions-Cast-a-pointer-with-reinterpret_cast.patch \
file://0002-Disable-a-faulty-chinese-collision-text-building.patch \
file://0003-Disable-tests-and-doc.patch \
file://0004-configure-Use-a-usr-prefix-by-default.patch"
SRCREV = "8ba84e50a3ea099a9582dfb99b27078a6cedde3e"
PR = "r1"
PV = "+git${SRCPV}"
S = "${WORKDIR}/git"
do_configure_prepend() {
../git/configure
sed -i "s@ICUBINDIR = \$\$system(icu-config --bindir)@ICUBINDIR = ${STAGING_DIR_NATIVE}/usr/bin/@" ../git/src/icu-extradata/icu-extradata.pro
}
DEPENDS += "qtbase icu-native qttools-native"
inherit qmake5
FILES_${PN}-dev += "/usr/share/mkspecs/ /usr/lib/libmlocale5.prl"
FILES_${PN}-dbg += "/usr/lib/libmlocale-benchmarks5 /usr/share/libmlocale-benchmarks5"
FILES_${PN} += "/usr/share/mlocale5"
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment