Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
M
meta-nemo
Project
Project
Details
Activity
Releases
Cycle Analytics
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Charts
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
CI / CD
CI / CD
Pipelines
Jobs
Schedules
Charts
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Charts
Create a new issue
Jobs
Commits
Issue Boards
Open sidebar
NemoMobile
meta-nemo
Commits
f53ef36c
Commit
f53ef36c
authored
Jul 30, 2017
by
Florent Revest
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
lipstick: Workaround the screenshot service by registering it on the system bus
parent
f2f68943
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
41 additions
and
0 deletions
+41
-0
0004-ScreenshotService-Use-system-bus-to-workaround-the-s.patch
...creenshotService-Use-system-bus-to-workaround-the-s.patch
+40
-0
lipstick_git.bb
recipes-nemomobile/lipstick/lipstick_git.bb
+1
-0
No files found.
recipes-nemomobile/lipstick/lipstick/0004-ScreenshotService-Use-system-bus-to-workaround-the-s.patch
0 → 100644
View file @
f53ef36c
From f2d63b3cbdbc941ad9e60123c2d3507ddf87e040 Mon Sep 17 00:00:00 2001
From: Florent Revest <revestflo@gmail.com>
Date: Sun, 30 Jul 2017 20:22:22 +0100
Subject: [PATCH] ScreenshotService: Use system bus to workaround the
sessionBus not being registered correctly
---
src/homeapplication.cpp | 3 +--
tools/screenshottool/screenshottool | 2 +-
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/src/homeapplication.cpp b/src/homeapplication.cpp
index 758e00b..6bb2b31 100644
--- a/src/homeapplication.cpp
+++ b/src/homeapplication.cpp
@@ -120,9 +120,8 @@
HomeApplication::HomeApplication(int &argc, char **argv, const QString &qmlPath)
m_screenshotService = new ScreenshotService(this);
new ScreenshotServiceAdaptor(m_screenshotService);
- QDBusConnection sessionBus = QDBusConnection::sessionBus();
- registerDBusObject(sessionBus, LIPSTICK_DBUS_SCREENSHOT_PATH, m_screenshotService);
+ registerDBusObject(systemBus, LIPSTICK_DBUS_SCREENSHOT_PATH, m_screenshotService);
// Setting up the context and engine things
qmlEngine->rootContext()->setContextProperty("initialSize", QGuiApplication::primaryScreen()->size());
diff --git a/tools/screenshottool/screenshottool b/tools/screenshottool/screenshottool
index 64d6b9a..56fd45a 100755
--- a/tools/screenshottool/screenshottool
+++ b/tools/screenshottool/screenshottool
@@ -15,5 +15,5 @@
else
fi
sleep "${DELAY}"
-dbus-send --type=method_call --dest=org.nemomobile.lipstick /org/nemomobile/lipstick/screenshot org.nemomobile.lipstick.saveScreenshot "string:${SCREENSHOTPATH}"
+dbus-send --system --type=method_call --dest=org.nemomobile.lipstick /org/nemomobile/lipstick/screenshot org.nemomobile.lipstick.saveScreenshot "string:${SCREENSHOTPATH}"
notificationtool -o add -c device.added "" "" "" "Screenshot saved to $SCREENSHOTPATH"
--
2.7.4
recipes-nemomobile/lipstick/lipstick_git.bb
View file @
f53ef36c
...
@@ -7,6 +7,7 @@ SRC_URI = "git://github.com/AsteroidOS/lipstick.git;protocol=https \
...
@@ -7,6 +7,7 @@ SRC_URI = "git://github.com/AsteroidOS/lipstick.git;protocol=https \
file://0001-Disables-tests-and-doc.patch \
file://0001-Disables-tests-and-doc.patch \
file://0002-notificationcategories-use-ion-icons.patch \
file://0002-notificationcategories-use-ion-icons.patch \
file://0003-Disable-USB-mode-notifications-on-connect.patch \
file://0003-Disable-USB-mode-notifications-on-connect.patch \
file://0004-ScreenshotService-Use-system-bus-to-workaround-the-s.patch \
file://Notifications/"
file://Notifications/"
SRCREV = "8ab7a05b049fd847a050f03871d101cd4a5e381a"
SRCREV = "8ab7a05b049fd847a050f03871d101cd4a5e381a"
PR = "r1"
PR = "r1"
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment